Skip site navigation (1) Skip section navigation (2)

Re: Problems when initdb on WinXP with SP2.

From: Thomas Harold <tgh(at)tgharold(dot)com>
To:
Cc: pgsql-admin(at)postgresql(dot)org
Subject: Re: Problems when initdb on WinXP with SP2.
Date: 2005-11-27 04:42:55
Message-ID: 4389394F.8080205@tgharold.com (view raw or flat)
Thread:
Lists: pgsql-admin
Johnson Zhao wrote:

> Hi,
> 
> I use Postgresql 8.03/ 8.04 on windows xp with sp2, all have same problems.
> 
> run the windows cmd by:
> 
> runas /user:postgres cmd
> 
> and run the initdb program like:
> 
> initdb --locale=C --username=postgres -W -A md5 -E UNICODE -D ../data
> 
> then it says:
> 
> creating directory ../data/ ... ok
> creating directory ../data/global ... ok
> creating directory ../data/pg_xlog ... ok
> creating directory ../data/pg_xlog/archive_status ... ok
> creating directory ../data/pg_clog ... ok
> creating directory ../data/pg_subtrans ... ok
> creating directory ../data/base ... ok
> creating directory ../data/base/1 ... ok
> creating directory ../data/pg_tblspc ... ok
> selecting default max_connections  ....
> 
> and the command window stayed there!

I have no idea whether this matters or not, but I got bit during an 8.1 
install by permissions issues.  The postgres user requires read/write 
permissions for the data folder and below, but it also requires read 
permissions all the way back to the root of the drive (including the 
root directory).

The specific situation for us was that we were trying to install to 
D:\PostgreSQL\Data, but the postgres user didn't have read permissions 
on the root of D:\ (or D:\PostgreSQL).

In response to

Responses

pgsql-admin by date

Next:From: Johnson ZhaoDate: 2005-11-28 02:03:26
Subject: Re: Problems when initdb on WinXP with SP2.
Previous:From: Qingqing ZhouDate: 2005-11-26 19:07:31
Subject: Re: Problems when initdb on WinXP with SP2.

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group