Skip site navigation (1) Skip section navigation (2)

Bug with version 08.01.0100 ?

From: Thomas Chabaud <tc(at)geosys(dot)com>
To: pgsql-odbc(at)postgresql(dot)org
Subject: Bug with version 08.01.0100 ?
Date: 2005-11-07 10:38:36
Message-ID: 436F2EAC.5000309@geosys.com (view raw or flat)
Thread:
Lists: pgsql-odbc
I have installed the new version of the Postgre ODBC driver with the msi
installer provided, but I have a Visual Basic abnormal error when I try
to open a recordset.

The conn.open works without problem, the error happens only when I try
to open the recordset with the following code :


Dim rs As New ADODB.Recordset
Dim sqlStr as String

sqlStr = "SELECT * FROM tUsers"
rs.Open sqlStr, dbConn, adOpenStatic, adLockOptimistic, adCmdText

- My conn.ConnectionString is :

Provider=MSDASQL.1;Extended Properties="DRIVER={PostgreSQL-libpq};
DATABASE=mybase;SERVER=myserver;PORT=5432;SSLMODE=prefer;
UID=postgres;PWD=postgres;ReadOnly=0;Protocol=6.4;FakeOidIndex=0;ShowOidColumn=1;RowVersioning=1;
ShowSystemTables=0;ConnSettings=;Fetch=100;Socket=4096;UnknownSizes=0;MaxVarcharSize=254;
MaxLongVarcharSize=8190;Debug=1;CommLog=1;Optimizer=1;Ksqo=3;UseDeclareFetch=0;TextAsLongVarchar=1;
UnknownsAsLongVarchar=0;BoolsAsChar=1;Parse=0;CancelAsFreeStmt=0;ExtraSysTablePrefixes=dd_;
LFConversion=1;UpdatableCursors=1;DisallowPremature=0;TrueIsMinus1=0;BI=0;ByteaAsLongVarBinary=0;
UseServerSidePrepare=0;LowerCaseIdentifier=0"

- And here is the log :

     [ PostgreSQL version string = 'PostgreSQL 8.0.4 on i686-pc-mingw32,
compiled
  by GCC gcc.exe (GCC) 3.4.2 (mingw-special)' ]
     [ PostgreSQL version number = '8.0' ]
conn=131349608, query='set DateStyle to 'ISO''
conn=131349608, query='set geqo to 'OFF''
conn=131349608, query='set extra_float_digits to 2'
conn=131349608, query='select oid from pg_type where typname='lo''
     [ Large Object oid = 17612 ]
conn=131349608, query='select pg_client_encoding()'
     [ Client encoding = 'SQL_ASCII' (code = 0) ]
conn=131349608,
PGAPI_DriverConnect(out)='DRIVER={PostgreSQL-libpq};DATABASE=mybase;SERVER=myserver;
PORT=5432;SSLMODE=prefer;UID=postgres;PWD=xxxxxxxx;ReadOnly=0;
Protocol=6.4;FakeOidIndex=0;ShowOidColumn=1;RowVersioning=1;ShowSystemTables=0;C
onnSettings=;Fetch=100;Socket=4096;UnknownSizes=0;MaxVarcharSize=254;MaxLongVarc
harSize=8190;Debug=1;CommLog=1;Optimizer=1;Ksqo=3;UseDeclareFetch=0;TextAsLongVa
rchar=1;UnknownsAsLongVarchar=0;BoolsAsChar=1;Parse=0;CancelAsFreeStmt=0;ExtraSy
sTablePrefixes=dd_;LFConversion=1;UpdatableCursors=1;DisallowPremature=0;TrueIsM
inus1=0;BI=0;ByteaAsLongVarBinary=0;UseServerSidePrepare=0;LowerCaseIdentifier=0
'
DESCRIPTOR ERROR: func=PGAPI_SetDescField, desc='', errnum=11,
errmsg='bad param
eter number'

I hope you can help me.

Thanks in advance.

Thomas Chabaud


pgsql-odbc by date

Next:From: Dave PageDate: 2005-11-07 10:54:43
Subject: Re: Bug with version 08.01.0100 ?
Previous:From: Thomas ChabaudDate: 2005-11-07 08:45:21
Subject: Bug with version 08.01.0100 ?

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group