Skip site navigation (1) Skip section navigation (2)

Re: configure doesn't find my pgsql installation

From: Raphaël Enrici <blacknoz(at)club-internet(dot)fr>
To: Linuxer Wang <linuxerwang(at)gmail(dot)com>
Cc: pgadmin-hackers(at)postgresql(dot)org
Subject: Re: configure doesn't find my pgsql installation
Date: 2005-06-05 19:32:19
Message-ID: 42A35343.4050507@club-internet.fr (view raw or flat)
Thread:
Lists: pgadmin-hackers
Linuxer Wang wrote:
> Raphaël Enrici wrote:
> 
> 
>>Hi,
>>
>>Linuxer Wang wrote:
>> 
>>
>>
>>>Hi, all
>>>
>>>I am using Fedora4test3, the Gcc is 4.0, when I tried to compile the
>>>pgadmin 1.2.2 source codes, I got the following errors by configure:
>>>
>>>checking pgsql in /usr/lib/pgsql... failed
>>>configure: error: you must specify a valid pgsql installation with
>>>--with-pgsql=DIR
>>>
>>>I changed the DIR to be /usr/share/pgsql and /usr/lib/pgsql, but the
>>>errors still occured.
>>>
>>>There is a post in the mailing list which fixed the bug, but in my
>>>instance, it seems don't work.
>>>
>>>Can anybody help me?
>>>
>>>Thank you in advance.
>>>   
>>>
>>
>>can you post your config.log and detail where the libs you are looking
>>for are supposed to be please?
>> 
>>
> 
> 
> Thank you for your reply, the file config.log is attached.
> 

according to what I read, configure does not find the file named
"libq-fe.h". This file should be located somewhere in /usr/include.
Did you install the package named postgresql-devel ?

Regards,
Raphaël

In response to

Responses

pgadmin-hackers by date

Next:From: Linuxer WangDate: 2005-06-05 19:38:58
Subject: Re: configure doesn't find my pgsql installation
Previous:From: Linuxer WangDate: 2005-06-05 19:26:25
Subject: Re: configure doesn't find my pgsql installation

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group