Skip site navigation (1) Skip section navigation (2)

Re: Postgres / Centos

From: Leonel Nunez <lnunez(at)enelserver(dot)com>
To: Patricio Muñoz <patricio(dot)munoz(at)cmet(dot)net>
Cc: pgsql-es-ayuda(at)postgresql(dot)org
Subject: Re: Postgres / Centos
Date: 2005-04-29 14:05:08
Message-ID: 42723F14.5030707@enelserver.com (view raw or flat)
Thread:
Lists: pgsql-es-ayuda
Patricio Muñoz wrote:

> Cristofer N. Reyes A. escribió:
>
>>> por lo cual debiera bajar los rpm de Postgres para rhel.
>>
>>
>>
>> Estas equivocado, desde un pc con CentOS 4.0:
>>
>> [root(at)server ~]# rpm -qa |grep postgresql
>> postgresql-server-7.4.7-2.RHEL4.1
>> postgresql-libs-7.4.7-2.RHEL4.1
>> postgresql-7.4.7-2.RHEL4.1
>>
>> lo que trae incluido en la distribucion, no tienes que buscarlo en 
>> ninguna parte.
>
>
> Pero no tiene sentido instalar esa version de Postgres, si ya esta en 
> la 8.0.2, y se han mejorado bastantes cosas.
>
asi es pero ...

Tendras que resolver todas las dependencias  ya que  postgresql 8.0.2  
usa libpq.so.4   y todos los programas de CentOS que dependen de 
PostgreSQL usan la libpq.so.3
por lo tanto   no solo es PostgreSQL el que tendreas que estar 
actualizando cuando salga la  8.0.3 o 8.1 si no todas las dependencias 
tendras que recompilarlas
eso sin contar el  DUMP and RELOAD  por cambio de version  o futuros 
cambios de versiones

realmente  usar la  7.4.7 de CentOS  te garantiza que por los  5 o 7 
años de vida de la distro  tendreas esa version de PostgreSQL  
actualizada de Bugs criticos.

como todo hay que ver lo que realmente se requiere para el trabajo.



Leonel


In response to

Responses

pgsql-es-ayuda by date

Next:From: Hugo GamarraDate: 2005-04-29 14:05:35
Subject: RE: Funcion que rellene campos
Previous:From: ramirexDate: 2005-04-29 13:54:43
Subject: Re: manejadores

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group