Skip site navigation (1) Skip section navigation (2)

Re: wx2.6

From: "Florian G(dot) Pflug" <fgp(at)phlo(dot)org>
To: pgadmin-hackers <pgadmin-hackers(at)postgresql(dot)org>
Subject: Re: wx2.6
Date: 2005-04-18 15:46:32
Message-ID: 4263D658.2020507@phlo.org (view raw or flat)
Thread:
Lists: pgadmin-hackers
Andreas Pflug wrote:
> I tested wx 2.6 on linux and win32, apparently it's ok. As soon as the 
> official package is out, nightly builds chould use that.
It works for OSX too. There is one very small problem I noticed - it's
the textedit-box that opens when editing a long "text"-value in the data-browser.
This edit-box doesn't always get it's size right - e.g, when the text
has only one line, the height is too small, and you end up seeing only
a abort 1/3 of the line. But, since I don't know what the correct behaviour
for this text-edit-thing is, and since on linux it also sometimes shows strange
behaviour, I chose to ignore that for now ;-)

> Besides using our ./configure options, no patch to wx sources should be 
> necessary; the 2.5.4 patch on wxUSE_DEPRECATED is already included.
So I don't need to call configure for wx and pgadmin with
"CPPFLAGS='wxUSE_DEPRECATED=0' ./configure ..." anymore?


greetings, Florian Pflug

In response to

  • wx2.6 at 2005-04-18 14:48:40 from Andreas Pflug

Responses

  • Re: wx2.6 at 2005-04-18 16:40:49 from Andreas Pflug

pgadmin-hackers by date

Next:From: Florian G. PflugDate: 2005-04-18 16:08:44
Subject: Re: OSX Update: Night Builds
Previous:From: Andreas PflugDate: 2005-04-18 14:48:40
Subject: wx2.6

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group