Skip site navigation (1) Skip section navigation (2)

Re: FC2 install cannot find libpq-fe.h

From: Raphaël Enrici <blacknoz(at)club-internet(dot)fr>
To: Richard_D_Levine(at)raytheon(dot)com
Cc: pgadmin-support(at)postgresql(dot)org
Subject: Re: FC2 install cannot find libpq-fe.h
Date: 2004-09-14 19:24:57
Message-ID: 41474589.3050908@club-internet.fr (view raw or flat)
Thread:
Lists: pgadmin-support
Hi Rick,

Richard_D_Levine(at)raytheon(dot)com wrote:
> I'm running Fedora Core 2 with PostgreSQL 7.4.5, and just installed
> wxWidgets 2.5 from the pgadmin mirrors as recommended.  I installed
> PostgreSQL using RPMs.  All of that went well and PostgreSQL is running
> nicely.
> 
> When I try to install pgadmin the configure command fails looking for
> libpq-fe.h.  I did a 'find / -name libpq-fe.h' and it is surely not on the
> machine.

In general linux distros separate headers from binaries so that you 
don't waste disk space with non-wanted files.
You should install the devel package. Try to install postgresql-devel 
rpm package, it should contain the files you need.

> I'm a Linux newbie, though not a Unix newbie, so don't worry about
> insulting my intelligence.  I ain't got none.

I heard someone around who told "there are only stupid answers, not 
questions...". As I'm not an FC2 expert, I hope my answer was not too 
stupid and that it will help you going further.

Regards,
Raphaël

pgadmin-support by date

Next:From: Alexander KirpaDate: 2004-09-14 20:23:09
Subject: Bug: pgAdmin III v1.2.0 Beta 1 - wrong color processing in COMMENT
Previous:From: Devrim GUNDUZDate: 2004-09-14 18:05:11
Subject: Re: pgadmin3 for FC2

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group