Skip site navigation (1) Skip section navigation (2)

Announcing postgresql-sdbc-0.6.1 driver of OpenOffice.org

From: Joerg Budischewski <joerg(at)budischewski(dot)com>
To: pgsql-announce(at)postgresql(dot)org
Subject: Announcing postgresql-sdbc-0.6.1 driver of OpenOffice.org
Date: 2004-07-11 10:35:00
Message-ID: 40F117D4.5040005@budischewski.com (view raw or flat)
Thread:
Lists: pgsql-announce
Hi,

I'd like to announce the availability of the version 0.6.1 of the native 
postgresql driver for OpenOffice.org database API for windows and linux x86.

The driver's homepage can be found here:

http://dba.openoffice.org/drivers/postgresql/index.html

Compared to Version 0.6.0, there are only two changes (see below). In 
case, the described problems don't affect you, there is no reason to 
upgrade:

Changes:
* Data type handling
Some postgresql data types are not yet correctly suppported by the 
driver ( arrays, blobs and 'esoteric types' such as circle, point, 
etc.). In prior version, values of this type were not displayed by the 
driver at all. Now, they are shown in their default string 
representation, which also allows modification of the values.
All these types get currently mapped to the OOo Memo type, this is 
recognizable in the Edit-table window, where they are grouped together 
in the type selection box.

* Named parameters in prepared statements (or subform support)
In prior versions, only a '?' as a placeholder in prepared statements 
was supported, which did not work out properly with subforms. Now 
additionally named parameters (e.g. ':x' or ':myvar') are supported, 
which allows full subform support.

About the driver:

The driver allows to directly use the postgresql database from 
OpenOffice.org without any other wrapper layer such as odbc or jdbc.
The driver is aimed at the 1.1 OpenOffice.org versions, it should not 
work with OOo1.0.x trees. It should work with OOo2.0 developer versions, 
but this has not been tested yet.
It should work with all postgresql servers of the 7.3.x and 7.4.x 
versions, 7.2.x is known not to work.

Have fun,

Joerg

PS: followups in dev(at)dba(dot)openoffice(dot)org


pgsql-announce by date

Next:From: Robert TreatDate: 2004-07-13 03:59:11
Subject: == PostgreSQL Weekly News - July 12th 2004 ==
Previous:From: Robert TreatDate: 2004-07-07 03:59:22
Subject: == PostgreSQL Weekly News - July 6th 2004 ==

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group