Skip site navigation (1) Skip section navigation (2)

Re: Upgrading from 7.3.4 til 7.4.x?

From: Oliver Jowett <oliver(at)opencloud(dot)com>
To: Bjørn T Johansen <btj(at)havleik(dot)no>
Cc: "pgsql-jdbc(at)postgresql(dot)org" <pgsql-jdbc(at)postgresql(dot)org>
Subject: Re: Upgrading from 7.3.4 til 7.4.x?
Date: 2004-03-10 13:15:50
Message-ID: 404F1506.9010603@opencloud.com (view raw or flat)
Thread:
Lists: pgsql-jdbc
Bjørn T Johansen wrote:
> I am running 7.3.4 and I am thinking about upgrading to 7.4, so I was 
> just wondering what pitfalls, etc I should know of?

You will definitely need a 7.4-era JDBC driver due to the autocommit 
changes between 7.3 and 7.4. Upgrading to a newer driver may expose 
application bugs e.g. expecting getFetchSize() to return the number of 
result rows; otherwise it should be compatible.

-O

In response to

pgsql-jdbc by date

Next:From: Kris JurkaDate: 2004-03-10 16:01:40
Subject: Re: Backup of users and groups?
Previous:From: Dave CramerDate: 2004-03-10 13:14:37
Subject: Re: Backup of users and groups?

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group