Skip site navigation (1) Skip section navigation (2)

ant wants to build a J2EE jdbc driver (I only want a J2SE driver!)

From: Jerry Asher <jerry(at)hollyjerry(dot)org>
To: <pgsql-cygwin(at)postgresql(dot)org>
Subject: ant wants to build a J2EE jdbc driver (I only want a J2SE driver!)
Date: 2001-05-31 03:20:52
Message-ID: 4.3.2.7.2.20010530201858.00c03b30@hollyjerry.org (view raw or flat)
Thread:
Lists: pgsql-cygwin
I am trying to build postgresql 7.1.2 on NT using the cygwin package.  I am 
using jdk 1.3.1 Standard Edition.

I configured the system to build the jdbc driver

    ./configure --with-java

and then I ran make.

Everything is seemingly succesful until it starts building the jdbc driver, 
which reports 100 errors similar to:

Administrator(at)DUALBERT:c:/cygnus/usr/src/postgresql-7.1.2$ ant
Buildfile: build.xml

jar:

call:

prepare:

check_versions:

driver:
      [echo] Configured build for the JDBC2 Enterprise edition driver.

compile:
     [javac] Compiling 58 source files to 
C:\cygnus\usr\src\postgresql-7.1.2\src\interfaces\jdbc\build
     [javac] 
C:\cygnus\usr\src\postgresql-7.1.2\src\interfaces\jdbc\org\postgresql\xa\XADataSourceImpl.java:64: 
cannot resolve symbol
     [javac] symbol  : class Xid
     [javac] location: package xa
     [javac] import javax.transaction.xa.Xid;
     [javac]                             ^
     [javac] 
C:\cygnus\usr\src\postgresql-7.1.2\src\interfaces\jdbc\org\postgresql\xa\XADataSourceImpl.java:237: 
cannot resolve symbol
     [javac] symbol  : class Xid
     [javac] location: class org.postgresql.xa.XADataSourceImpl
     [javac]     TxConnection getTxConnection( Xid xid )
     [javac]                                   ^

A brief check at Sun seems to indicate that the javax.transaction.xa.Xid 
class comes with the jdk1.4 that apparently is still in beta.  (I say this 
as I cannot find any Xid references in the 1.3 documentation.)

Of course, I note too that ANT is trying to build a JDBC2 Enterprise 
edition driver.  Hmm.  I only have the JDK Standard Edition loaded.  That 
would appear to be a problem, but what do I do about it?

Yet, when I build postgres 7.1.1 on Linux with the JDK 1.3.1 Standard 
Edition, I dont' receive these errors (and the underlying jdbc driver 
source code looks the same.)

Can you advise?

Thank you,

Jerry Asher
=====================================================
Jerry Asher                       jerry(at)hollyjerry(dot)org
1678 Shattuck Avenue Suite 161    Tel: (510) 549-2980
Berkeley, CA 94709                Fax: (877) 311-8688


In response to

Responses

pgsql-cygwin by date

Next:From: Jerry AsherDate: 2001-05-31 04:06:59
Subject: Re: ant wants to build a J2EE jdbc driver (I only want a J2SE driver!)
Previous:From: Richard ChurchDate: 2001-05-31 02:22:10
Subject: Re: Start up and shutdown scripts for postgres on cygwin

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group