Skip site navigation (1) Skip section navigation (2)

Re: hardare config question

From: Vivek Khera <vivek(at)khera(dot)org>
To: Pgsql performance <pgsql-performance(at)postgresql(dot)org>
Subject: Re: hardare config question
Date: 2006-04-28 17:36:45
Message-ID: 3DFCE70E-E4BB-40AB-B27F-99E90E8159CA@khera.org (view raw or flat)
Thread:
Lists: pgsql-performance
On Apr 28, 2006, at 11:37 AM, Erik Myllymaki wrote:

> When I had this installed on a single SATA drive running from the  
> PE1800's on-board SATA interface, this operation took anywhere from  
> 65-80 seconds.
>
> With my new RAID card and drives, this operation took 272 seconds!?

switch it to RAID10 and re-try your experiment.  if that is fast,  
then you know your raid controller does bad RAID5.

anyhow, I have in one server (our office mail server and part-time  
development testing box) an adaptec SATA RAID from dell.  it is  
configured for RAID5 and does well for normal office stuff, but when  
we do postgres tests on it, it just is plain old awful.

but I have some LSI based cards on which RAID5 is plenty fast and  
suitable for the DB, but those are SCSI.

For what it is worth, the Dell PE1850 internal PERC4/Si card is  
wicked fast when hooked up with a pair of U320 SCSI drives.



In response to

Responses

pgsql-performance by date

Next:From: Bealach-na BoDate: 2006-04-28 17:37:30
Subject: Re: Why so slow?
Previous:From: Bealach-na BoDate: 2006-04-28 17:31:30
Subject: Re: Why so slow?

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group