Skip site navigation (1) Skip section navigation (2)

connection weirdness from MS Access when using ident and password

From: "David M(dot) Kaplan" <dmkaplan(at)ucdavis(dot)edu>
To: pgsql-odbc(at)postgresql(dot)org
Subject: connection weirdness from MS Access when using ident and password
Date: 2002-06-18 03:37:31
Message-ID: 3D0EAAFB.7060404@ucdavis.edu (view raw or flat)
Thread:
Lists: pgsql-odbc
Hi,

I recently experienced a weird bug with the ODBC driver (or postgresql). 
 I am running:

psqlodbc-07_02_0001
postgresql-server-7.2.1-5

I was trying to connect to a database using MS Access.  Initially, my 
pg_hba.conf looked like:

host       all         127.0.0.1     0.0.0.0    ident    sameuser
host    all    192.168.1.2    255.255.255.128    password

where my machine is 192.168.1.1 and the MS client is 192.168.1.2. 
 Connecting using ODBC failed with this configuration stating:

FATAL 1: IDENT authentification failed for user 'me' (#210)

Then I changed the order of the lines in my configuration file:

host    all    192.168.1.2    255.255.255.128    password
host       all         127.0.0.1     0.0.0.0    ident    sameuser

Now the ODBC connection worked with out problems.  In the first case, it 
seems to be trying to use IDENT authentification, even though that 
should only apply to localhost.

David K.



pgsql-odbc by date

Next:From: Dave PageDate: 2002-06-18 07:22:34
Subject: Re: ODBC questions
Previous:From: Timothy ReavesDate: 2002-06-17 23:53:20
Subject: ODBC questions

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group