Skip site navigation (1) Skip section navigation (2)

ODBC problem

From: Graeme Leeming <gleeming(at)refractions(dot)net>
To: bugs(at)safe(dot)com, pgsql-odbc(at)postgresql(dot)org
Subject: ODBC problem
Date: 2002-01-14 20:06:35
Message-ID: 3C433A4B.82F0A8D2@refractions.net (view raw or flat)
Thread:
Lists: pgsql-odbc
I have upgraded to build 537 of FME on WinNT and am trying to connect to
a Postgresql database through ODBC (this has worked properly with build
519 and PSQLodbc v7.01.00.05/6).  The error message I get back from the
translator is:

"[NOTSUPPORTED] The specified ODBC Data Source uses an ODBC driver which
conforms to an ODBC specification prior to the 3.0 specification.  This
driver version is not supported by DBTools.h++.  Please upgrade to a
newer driver.' (VendorMessage1=`', VendorMessage2=`')"

I tried using the latest version of PSQLODBC I could find, 7.01.00.09,
but still the same error occurs.  Since I don't know what the 3.0
specification entails, is there a way around this apparent limitation
now imposed by the new build of FME, and/or is a 3.0 compliant ODBC
driver available or planned for Postgres?

Graeme Leeming
Refractions Research Inc.


Responses

pgsql-odbc by date

Next:From: Dave PageDate: 2002-01-14 21:39:56
Subject: Re: transfer from Access2000 to postgreSQL
Previous:From: Luis AmigoDate: 2002-01-14 13:12:42
Subject: Re: LWLock contention: I think I understand the problem

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group