Skip site navigation (1) Skip section navigation (2)

Re: error message: the driver doesn't support the version of

From: Hiroshi Inoue <Inoue(at)tpf(dot)co(dot)jp>
To: "A(dot) Hahnefeld" <ahahnefeld(at)rjm(dot)de>
Cc: pgsql-odbc(at)postgresql(dot)org
Subject: Re: error message: the driver doesn't support the version of
Date: 2001-10-18 00:43:46
Message-ID: 3BCE25C2.59F24FFC@tpf.co.jp (view raw or flat)
Thread:
Lists: pgsql-odbc
"A. Hahnefeld" wrote:
> 
> Hi,
> 
> I'm trying to connect my PgSQL database (v 7.1.2) via the PostgreSQl-ODBC
> driver (v 7.01.00.07).
> I'm accessing from Delphi the "SQLDriverConnect" function via the ODBC32.DLL
> (v 3.520.6019.0).
> In my opinion I use the correct connection parameters 'cause a connection is
> made.
> The problem is that the connection will be closed immediately with a strange
> error message:
> "The driver doesn't support the version of the odbc-function, which is
> needed (notice SQLSetEnvAttr)"
> (This NOT the original message, 'cause it's a translation the original into
> english)

Your tool seems an ODBC 3.x application.
Unfortunately psqlodbc driver is ODBC 2.5. 

regards,
Hiroshi Inoue

In response to

pgsql-odbc by date

Next:From: Keith GrayDate: 2001-10-18 00:57:29
Subject: BUG - possible UPDATE bug in multi-record?
Previous:From: Henshall, Stuart - WCPDate: 2001-10-17 08:52:48
Subject: Re: PgSQL vs Ms.Access slow in search

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group