Skip site navigation (1) Skip section navigation (2)

Re: ERROR: parser: parse error at or near "JOIN"

From: Fernando Nasser <fnasser(at)redhat(dot)com>
To: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
Cc: pgsql-hackers(at)postgresql(dot)org
Subject: Re: ERROR: parser: parse error at or near "JOIN"
Date: 2001-04-25 16:09:04
Message-ID: 3AE6F6A0.4F38748@redhat.com (view raw or flat)
Thread:
Lists: pgsql-hackers
Tom Lane wrote:
> 
> Fernando Nasser <fnasser(at)redhat(dot)com> writes:
> > Is anyone else seeing this?
> 
> No.
> 
> > I have the current CVS sources and "make check" ends up with one
> > failure.  My regression.diffs shows:
> 
> I think you must have built gram.c with a broken bison or yacc.  What
> exactly is configure picking, and what version is it?
> 

Yes you are right.

With:

[12:03:04] > flex -V
flex version 2.5.4
                                                                              
[12:03:08] > bison -V
GNU Bison version 1.28

it fails, but using older versions of flex and bison the regression goes
away:

[12:05:30] > flex -V
flex Cygnus version 2.5-gnupro-99r1

[12:05:34] > bison -V
GNU Bison version 1.25


Thank you very much.




-- 
Fernando Nasser
Red Hat Canada Ltd.                     E-Mail:  fnasser(at)redhat(dot)com
2323 Yonge Street, Suite #300
Toronto, Ontario   M4P 2C9

In response to

Responses

pgsql-hackers by date

Next:From: Tom LaneDate: 2001-04-25 16:42:07
Subject: Re: Any optimizations to the join code in 7.1?
Previous:From: Tom LaneDate: 2001-04-25 15:48:13
Subject: Re: ERROR: parser: parse error at or near "JOIN"

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group