Skip site navigation (1) Skip section navigation (2)

Re: BUG

From: Alexia Lau <alau(at)esri(dot)com>
To: "'PostgreSQL Bugs'" <pgsql-bugs(at)postgresql(dot)org>
Cc: "'dharmendra(dot)goyal(at)enterprisedb(dot)com'" <dharmendra(dot)goyal(at)enterprisedb(dot)com>, Alexia Lau <alau(at)esri(dot)com>
Subject: Re: BUG
Date: 2010-10-23 02:09:09
Message-ID: 3A7E5C30129F044287D9075DA04CC395085CBF1CFD@redmx1.esri.com (view raw or flat)
Thread:
Lists: pgsql-bugs
Hi Dharmendra,

I am encountering the same exact problem with the 9.0 one-click installer for Linux from EnterpriseDB on SUSE 11 and RedHat 5.5 with the latest release this week.  In your email dated 9/28/10, you indicated it's fixed.  Will you fix it for SUSE 11 and RedHat 5.5?

Sincerely,
Alexia

________________________________


Author: Dharmendra Goyal
Date:  2010-09-28 02:36  -700
To: Andrew Geery
CC: pgsql-bugs
Subject: Re: [BUGS] BUG #5677: missing libuuid.so.16 library
Hi Andrew,

I have fixed this issue. Thanks for reporting.

Regards,
Dharmendra

On Sat, Sep 25, 2010 at 8:10 AM, Andrew Geery <andrew(dot)geery(at)???>wrote:

>
> The following bug has been logged online:
>
> Bug reference: 5677
> Logged by: Andrew Geery
> Email address: andrew(dot)geery(at)???
> PostgreSQL version: 9.0
> Operating system: Ubuntu 10.10
> Description: missing libuuid.so.16 library
> Details:
>
> In 8.4, the one-click installer for Linux from EDB included the libuuid.so*
> libraries in the PGLIB directory. However, in the 9.0 one-click installer
> for Linux from EDB, these libraries are no longer included. On Ubuntu
> 10.10, attempting to run the uuid-ossp.sql script produces this error
> because of the missing libuuid* libraries:
>
> ERROR: could not load library
> "/opt/PostgreSQL/9.0/lib/postgresql/uuid-ossp.so": libuuid.so.16: cannot
> open shared object file: No such file or directory
> SQL state: 58P01
>
> The workaround is to copy the libuuid* libraries from the 8.4 installation
> into the 9.0 PGLIB directory.
>
> Not sure why those libraries were removed in 9.0 -- I was unable to find an
> Ubuntu package that supplied libuuid.so.16. In /lib, there are
> libuuid.so.1
> and libuuid.so.1.3.0, but symbolically linking them to libuuid.so.16
> failed.
>
> Thanks
> Andrew
>
> --
> Sent via pgsql-bugs mailing list (pgsql-bugs(at)???)
> To make changes to your subscription:
> http://www.postgresql.org/mailpref/pgsql-bugs
>



--

Dharmendra Goyal

Senior Software Engineer

EnterpriseDB Corporation

The Enterprise Postgres Company


Phone: +91-20-30589493
Mobile: +91-9552103323

Website: http://www.enterprisedb.com
EnterpriseDB Blog: http://blogs.enterprisedb.com/
Follow us on Twitter: http://www.twitter.com/enterprisedb

This e-mail message (and any attachment) is intended for the use of the
individual or entity to whom it is addressed. This message contains
information from EnterpriseDB Corporation that may be privileged,
confidential, or exempt from disclosure under applicable law. If you are not
the intended recipient or authorized to receive this for the intended
recipient, any use, dissemination, distribution, retention, archiving, or
copying of this communication is strictly prohibited. If you have received
this e-mail in error, please notify the sender immediately by reply e-mail
and delete this message.

Responses

  • Re: BUG at 2010-10-25 05:03:49 from Dharmendra Goyal

pgsql-bugs by date

Next:From: Craig RingerDate: 2010-10-23 04:46:31
Subject: Re: BUG #5720: Bug for PQescapeByteaConn (libpq)
Previous:From: Alexia LauDate: 2010-10-23 01:56:59
Subject: BUG #5721: EnterpriseDB linux one-click installer missing libuuid.so.16

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group