Skip site navigation (1) Skip section navigation (2)

Re: RPM install weirdness & BugreportPage Bug

From: Lamar Owen <lamar(dot)owen(at)wgcr(dot)org>
To: Thomas Linden <tom(at)daemon(dot)de>
Cc: pgsql-bugs(at)postgresql(dot)org
Subject: Re: RPM install weirdness & BugreportPage Bug
Date: 2000-11-02 15:03:00
Message-ID: 3A018224.F1C1AAA7@wgcr.org (view raw or flat)
Thread:
Lists: pgsql-bugs
Thomas Linden wrote:
> I suggest a little bit more investigation and testing before publishing
> rpm packages, a rpm package must be installable unless it cannot find a
> required package. if this is the case, then this package must be

You must put all the RPM's on the same command line invocation, or it
won't work.  There are circular dependencies in the old packaging, which
cannot be rid of unless you upgrade all at once.

Although, you may still get problems with the postgresql-data package --
like Thomas said, you may be better off dumping your data then
uninstalling the old RPM's, and then installing the new.

Are you running RedHat 6.x?  RedHat 6.0 shipped PostgreSQL 6.4.2, RH 6.1
shipped 6.5.2, and 6.2 shipped 6.5.3.  RedHat 7 shipped 7.0.2.  RedHat
5.2 was the last RedHat release that shipped 6.3.2.
--
Lamar Owen
WGCR Internet Radio
1 Peter 4:11

In response to

Responses

pgsql-bugs by date

Next:From: Moritz GmelinDate: 2000-11-02 15:27:16
Subject: Bug in Time/Date routines
Previous:From: pgsql-bugsDate: 2000-11-02 13:25:45
Subject: Bug#94 is related to compiler-version

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group