Skip site navigation (1) Skip section navigation (2)

Re: [HACKERS] CLASSOID patch

From: Chris Bitmead <chrisb(at)nimrod(dot)itg(dot)telstra(dot)com(dot)au>
To: Peter Eisentraut <peter_e(at)gmx(dot)net>, Chris Bitmead <chris(at)bitmead(dot)com>, Postgres Hackers List <hackers(at)postgresql(dot)org>, "pgsql-patches(at)postgresql(dot)org" <pgsql-patches(at)postgresql(dot)org>
Subject: Re: [HACKERS] CLASSOID patch
Date: 2000-06-26 04:48:13
Message-ID: 3956E08D.530B334A@nimrod.itg.telecom.com.au (view raw or flat)
Thread:
Lists: pgsql-hackerspgsql-patches
Chris Bitmead wrote:
> 
> Peter Eisentraut wrote:
> >
> > Chris Bitmead writes:
> >
> > > Attached is a first attempt at implementing the classoid feature.
> >
> > I'm wondering what other people think about the naming. Firstly, it's my
> > feeling that TABLEOID would be more in line with the general conventions.
> 
> I was thinking this myself today. Mainly because I wonder if in the
> future there may be support for more than one table implementing a
> particular class type. On the other hand the oid is a reference to the
> pg_class table. Maybe pg_class should be renamed pg_table? Anyway, my
> current thinking is that tableoid is better.

Or put another way, I see SQL3 has a feature S051 "CREATE TABLE
<tablename> OF <type>", and it seems maybe the <type> should be called a
class, and the table a collection of that class. This would advocate the
tableoid name I think. Someone please correct me if my thinking is
muddled here.

In response to

pgsql-hackers by date

Next:From: Ed LoehrDate: 2000-06-26 04:56:24
Subject: Re: Server process exited with status 139 (meaning?)
Previous:From: Tom LaneDate: 2000-06-26 04:35:44
Subject: Re: Server process exited with status 139 (meaning?)

pgsql-patches by date

Next:From: Hiroshi InoueDate: 2000-06-26 10:18:48
Subject: RE: [HACKERS] CLASSOID patch
Previous:From: Chris BitmeadDate: 2000-06-26 03:36:48
Subject: Re: CLASSOID patch

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group