Skip site navigation (1) Skip section navigation (2)

Cluster fails

From: Mark Kirkwood <markir(at)ihug(dot)co(dot)nz>
To: pgsql-bugs(at)postgresql(dot)org
Subject: Cluster fails
Date: 2000-05-10 07:42:12
Message-ID: 391912D4.14CD6D2B@ihug.co.nz (view raw or flat)
Thread:
Lists: pgsql-bugs
Your name                     :Mark Kirkwood
Your email address      :markir(at)ihug(dot)co(dot)nz


System Configuration
---------------------
  Architecture (example: Intel Pentium)         :Intel Pentuim

  Operating System (example: Linux 2.0.26 ELF)  :Linux 2.2.14-5.0 ELF
(Redhat 6.2)

  PostgreSQL version (example: PostgreSQL-6.5.1):7.0RC4

  Compiler used (example:  gcc 2.8.0)           :egcs-2.91.66


Please enter a FULL description of your problem:
------------------------------------------------
command  "cluster indexname on tablename" fails with text
"ERROR : temp123456abc is an index relation".
tablename and indexname are missing from pg_class, but
tablename still exists in the data directory


Please describe a way to repeat the problem.   Please try to provide a
concise reproducible example, if at all possible:
----------------------------------------------------------------------

create table testit ( id integer);
create index testit_i on testit( id );
cluster testit_i on testit;

If you know how this problem might be fixed, list the solution below:
---------------------------------------------------------------------


pgsql-bugs by date

Next:From: Peter EisentrautDate: 2000-05-10 21:24:34
Subject: Re: Error in pgaccess (parse error at or near """) on create new user with password
Previous:From: Tom LaneDate: 2000-05-09 14:01:00
Subject: Re: Error in pgaccess (parse error at or near """) on create new user with password

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group