Skip site navigation (1) Skip section navigation (2)

Re: [INTERFACES] Error using Perl interface

From: Thomas Lockhart <lockhart(at)alumni(dot)caltech(dot)edu>
To: "Mengelbier, Magnus" <Magnus(dot)Mengelbier(at)clinicaldatacare(dot)com>
Cc: pgsql-interfaces(at)postgreSQL(dot)org
Subject: Re: [INTERFACES] Error using Perl interface
Date: 1999-08-17 14:30:26
Message-ID: 37B97202.B61B8626@alumni.caltech.edu (view raw or flat)
Thread:
Lists: pgsql-interfaces
> We wonder if anyone has found and resolved an error we recieve when trying
> to connect to a PostgreSQl 6.5.1 database with perl 5.0053.
...
> We are running Red Hat 6.0 standard installation with PostgreSQL 6.5.1 and
> the perl interface that was available. We opted to install the binaries
> instead of compiliing the source ourselves.  We are running Perl 5.0053 that
> was installed with the system installation.

Which "binaries" did you install, and from what source? RedHat
currently uses a cheat to install perl (and a few other kinds of
things) in that they stuff *all* generated code into the "version
neutral" perl library area. So something built for perl-5.004x, as
were rpms posted at postgresql.org, will have been built and linked
for that version, but perl doesn't know that.

Anyway, I'm guessing that if you pick up the src.rpm for Postgres, and
build it on your system, it will start working.

I'm sure that there is a better way, like

  rpm --rebuild postgresql-6.5.1-src.rpm

but I haven't actually tried running that way since I've been building
the rpms. I do know that something like

  rpm -ivv postgresql-6.5.1-src.rpm
  cd /usr/src/redhat/SPECS
  rpm -ba postgresql-6.5.1.spec
  cd ../RPMS/i386

will get you new rpms for your platform, built against your tools.

Good luck.

                      - Thomas

-- 
Thomas Lockhart				lockhart(at)alumni(dot)caltech(dot)edu
South Pasadena, California

In response to

Responses

pgsql-interfaces by date

Next:From: Jens FelberDate: 1999-08-17 14:58:34
Subject: PL/PGSQL
Previous:From: Tom LaneDate: 1999-08-17 13:49:35
Subject: Re: [INTERFACES] Error using Perl interface

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group