Skip site navigation (1) Skip section navigation (2)

Re: Unknown winsock error 10061

From: Wojciech Strzałka <wstrzalka(at)gmail(dot)com>
To: Dave Page <dpage(at)pgadmin(dot)org>
Cc: pgsql-bugs(at)postgresql(dot)org
Subject: Re: Unknown winsock error 10061
Date: 2009-07-06 21:48:35
Message-ID: 3310658427.20090706234835@gmail.com (view raw or flat)
Thread:
Lists: pgsql-bugs
I don't suppose this explains anything but - why not to try (this is
DEBUG and has more details, but looks like some information are less detailed than in
INFO log level ?? (ie. socket error code is missing):

2009-07-06 23:31:12 CEST DEBUG:  00000: shmem_exit(0)
2009-07-06 23:31:12 CEST LOCATION:  shmem_exit, .\src\backend\storage\ipc\ipc.c:164
2009-07-06 23:31:12 CEST DEBUG:  00000: exit(0)
2009-07-06 23:31:12 CEST LOCATION:  proc_exit, .\src\backend\storage\ipc\ipc.c:116
2009-07-06 23:31:12 CEST DEBUG:  00000: forked new backend, pid=1468 socket=944
2009-07-06 23:31:12 CEST LOCATION:  BackendStartup, .\src\backend\postmaster\postmaster.c:2850
2009-07-06 23:31:12 CEST DEBUG:  00000: reaping dead processes
2009-07-06 23:31:12 CEST LOCATION:  reaper, .\src\backend\postmaster\postmaster.c:2082
2009-07-06 23:31:12 CEST DEBUG:  00000: server process (PID 3096) exited with exit code 0
2009-07-06 23:31:12 CEST LOCATION:  LogChildExit, .\src\backend\postmaster\postmaster.c:2509
2009-07-06 23:31:12 CEST DEBUG:  00000: forked new backend, pid=7868 socket=908
2009-07-06 23:31:12 CEST LOCATION:  BackendStartup, .\src\backend\postmaster\postmaster.c:2850
FATAL:  could not reattach to shared memory (key=248, addr=02100000): 487
2009-07-06 23:31:12 CEST LOG:  00000: loaded library "$libdir/plugins/plugin_debugger.dll"
2009-07-06 23:31:12 CEST LOCATION:  load_libraries, .\src\backend\utils\init\miscinit.c:1187
2009-07-06 23:31:12 CEST DEBUG:  00000: postgres child[7868]: starting with (
2009-07-06 23:31:12 CEST LOCATION:  BackendRun, .\src\backend\postmaster\postmaster.c:3198
2009-07-06 23:31:12 CEST DEBUG:  00000:         postgres
2009-07-06 23:31:12 CEST LOCATION:  BackendRun, .\src\backend\postmaster\postmaster.c:3201
2009-07-06 23:31:12 CEST DEBUG:  00000:         -v196608
2009-07-06 23:31:12 CEST LOCATION:  BackendRun, .\src\backend\postmaster\postmaster.c:3201
2009-07-06 23:31:12 CEST DEBUG:  00000:         -y
2009-07-06 23:31:12 CEST LOCATION:  BackendRun, .\src\backend\postmaster\postmaster.c:3201
2009-07-06 23:31:12 CEST DEBUG:  00000:         onebigdb
2009-07-06 23:31:12 CEST LOCATION:  BackendRun, .\src\backend\postmaster\postmaster.c:3201
2009-07-06 23:31:12 CEST DEBUG:  00000: )
2009-07-06 23:31:12 CEST LOCATION:  BackendRun, .\src\backend\postmaster\postmaster.c:3203
2009-07-06 23:31:12 CEST DEBUG:  00000: InitPostgres
2009-07-06 23:31:12 CEST LOCATION:  PostgresMain, .\src\backend\tcop\postgres.c:3347
2009-07-06 23:31:12 CEST DEBUG:  00000: reaping dead processes
2009-07-06 23:31:12 CEST LOCATION:  reaper, .\src\backend\postmaster\postmaster.c:2082
2009-07-06 23:31:12 CEST DEBUG:  00000: server process (PID 1468) exited with exit code 1
2009-07-06 23:31:12 CEST LOCATION:  LogChildExit, .\src\backend\postmaster\postmaster.c:2509
2009-07-06 23:31:12 CEST DEBUG:  00000: StartTransaction

Is there any way I could help with problem investigation?

Maybe some prepared version with extra debug.

Setting up build env. looks quite crazy but I could try
with some help (this will take quite long time assuming my free time,
but if there is no other way ...).



> 2009/7/6 Wojciech Strzałka <wstrzalka(at)gmail(dot)com>:
>>
>>  No really a pattern.
>>  I'm sure PG is installed in standard pure version everywhere.
>>  No domains at all.
>>  The rest is really custom (we are working remotely - each of us with
>>  different hardware, OS, software, etc...).
>>  Maybe the intel dual core has smth to do about it ?

> I run a core 2 duo and have never seen any problems. I don't exactly
> hammer the server though.

>>  Those are affected:
>>
>>  My machine is:
>>  Latitude D620, T7200, 3GB RAM, Vista Business SP2, NOD32 3.2, Windows Firewall
>>
>>  Guy 1:
>>  Latitude D620, T7200, 2GB RAM, XP Prof SP3, NOD32 3.2, OutpostFirewall
>>
>>  Guy 2:
>>  HP T5600 3GB RAM,XP SP2, F-Internet Security 2009
>>
>>  Guy 3: Acer (2 core also!!), 4GB RAM, Vista Sp2, Norton Ativirus
>>
>>
>>  Which is 4 of 8 in the team.

> What about those that don't see the problem? I'll grant you those 4
> are pretty different though.






-- 
Pozdrowienia,
 Wojciech Strzałka


In response to

Responses

pgsql-bugs by date

Next:From: Alvaro HerreraDate: 2009-07-06 22:06:18
Subject: Re: Unknown winsock error 10061
Previous:From: Oscar Miguel Amezcua EstrellaDate: 2009-07-06 19:47:50
Subject: BUG #4903: Sugestion a db modele like mysql workbrench

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group