Dave Page wrote:
> Kris Jurka wrote:
>> Running configure --with-wx-version=2.6 succeeds and then bails out
>> during the build process. If pgadmin requires 2.8 it should enforce
>> that at configure time.
> Agreed - configure check committed to SVN.
That broke build process (you couldn't even force specific version) on
Ubuntu Fiesty (and possibly Debian), as one can have more than one
wx-widgets version installed and default wouldn't be necessary the best
In fact, Ubuntu Fiesty defaults to 2.6.x, and so the check used
in ./configure (wx-config --version) gives 2.6.3, where
(wx-config --version=2.8 --version) gives 2.8.1.
So I created really ugly patch (as am really I not into shell scripting, nor
m4 macros), to fix it, but it might not work with non-debian wx-config
versions, so please doublecheck/improve (strongly recommended ! :-).
Well, in fact all major-minor version checking magic might be probably
thrown away, as we are asking wx-config for specific versions anyway.
Ugly (but works-for-me) patch attached.
In response to
pgadmin-hackers by date
|Next:||From: Erwin Brandstetter||Date: 2007-06-03 17:26:33|
|Subject: Re: Testing 1.7: issues in edit grid & query window|
|Previous:||From: Erwin Brandstetter||Date: 2007-06-01 23:09:27|
|Subject: Testing 1.7: issues in edit grid & query window|