Skip site navigation (1) Skip section navigation (2)

Re: Having problem with postgresql configuration (template1 doesn't

From: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
To: Vinicius <cviniciusm(at)terra(dot)com(dot)br>
Cc: pgsql-admin(at)postgresql(dot)org
Subject: Re: Having problem with postgresql configuration (template1 doesn't
Date: 2005-02-21 16:15:05
Message-ID: 320.1109002505@sss.pgh.pa.us (view raw or flat)
Thread:
Lists: pgsql-admin
Vinicius <cviniciusm(at)terra(dot)com(dot)br> writes:
> /var/log/messages shows:
> "...
> Feb 21 09:10:43 ronin kernel: audit(1108987843.094:0): avc:  denied  { 
> read } for  pid=6766 exe=/usr/bin/postgres path=/tmp/sh-thd-1108997049 
> (deleted) dev=dm-0 ino=1046660 scontext=user_u:system_r:postgresql_t 
> tcontext=user_u:object_r:tmp_t tclass=file

> And I still don't get the template1 database.

Sigh.  I coulda sworn I tested this in December, but it's definitely
busted now:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=149237
(I might have messed up by only testing PG 8.0 --- 8.0 does not have
this problem, since initdb is no longer a shell script.)

The short-term workaround is to temporarily disable selinux
(sudo /usr/sbin/setenforce 0) while you initialize the database.

			regards, tom lane

In response to

Responses

pgsql-admin by date

Next:From: Tom LaneDate: 2005-02-21 16:42:06
Subject: Re: pg_clog corrupt, can't start postgres
Previous:From: Anjan DaveDate: 2005-02-21 15:58:16
Subject: pg_clog corrupt, can't start postgres

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group