Skip site navigation (1) Skip section navigation (2)

Re: [INTERFACES] Can;t connect to db with pgaccess

From: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
To: Stan Brown <stanb(at)awod(dot)com>
Cc: PostgreSQL Interfaces <pgsql-interfaces(at)postgreSQL(dot)org>
Subject: Re: [INTERFACES] Can;t connect to db with pgaccess
Date: 1998-12-29 17:09:38
Message-ID: 29776.914951378@sss.pgh.pa.us (view raw or flat)
Thread:
Lists: pgsql-interfaces
Constantin Teodorescu <teo(at)flex(dot)ro> writes:
> Stan Brown wrote:
>> Downloaded the latest pgacess. Looks pretty neat. Unfortunatley it will
>> not connect to my 6.3 database.

> PgAccess 0.93 will work fine on PostgreSQL 6.4 and higher.
> Due to some enhancements made in libpgtcl, there is another option to
> pg_result (-error) that does not exist in PosgreSQL 6.3.x

I think Stan's problem is at a lower level than that: 6.4 libpq will not
talk to a pre-6.4 server, period.  (It wants the 2.0 version of the
FE-to-BE protocol, which the older servers don't offer.  The other way
around, new server and old client, is no problem.)

6.4 libpgtcl won't work without 6.4 libpq, either.

You could put the PgAccess 0.93 Tcl code atop a 6.3.x libpgtcl and
libpq, and then it'd talk to older servers.  I dunno whether the
"-error" change that Constantin mentions is the only change that
would be needed in the Tcl code.

It'd probably be a more profitable use of your time to upgrade to
a 6.4(.1) server.  My experience is that 6.4 is a good deal more
stable than 6.3.x...

			regards, tom lane

Responses

pgsql-interfaces by date

Next:From: Constantin TeodorescuDate: 1998-12-29 17:33:46
Subject: Re: [INTERFACES] Can;t connect to db with pgaccess
Previous:From: Gianluca VianelloDate: 1998-12-29 16:10:35
Subject: Postgres SQL and DELPHI 3.0

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group