Skip site navigation (1) Skip section navigation (2)

Re: Upgrading our minimum required flex version for 8.5

From: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
To: Andrew Dunstan <andrew(at)dunslane(dot)net>
Cc: Alvaro Herrera <alvherre(at)commandprompt(dot)com>, Kevin Grittner <Kevin(dot)Grittner(at)wicourts(dot)gov>, pgsql-hackers(at)postgreSQL(dot)org
Subject: Re: Upgrading our minimum required flex version for 8.5
Date: 2009-07-02 15:32:12
Message-ID: 29594.1246548732@sss.pgh.pa.us (view raw or flat)
Thread:
Lists: pgsql-hackers
Andrew Dunstan <andrew(at)dunslane(dot)net> writes:
> Tom Lane wrote:
>> Right, this will only affect people doing development or otherwise
>> building from a CVS pull.

> Of course, that includes the whole buildfarm. We might need to ask some 
> people to upgrade there.

Yes.  What I was thinking of doing was committing a configure change to
reject flex < 2.5.31, and waiting to see how much of the buildfarm goes
red.

One point here is that if buildfarm owners update to more recent flex,
that will also affect their testing of back branches.  I think this
should be okay --- AFAICT from the CVS logs, all of the stuff we did to
be compatible with 2.5.31 was pre-7.4 and so all supported versions
should still work.  But we'd find out for sure ;-)

			regards, tom lane

PS: speaking of buildfarm, I don't see any REL8_4_STABLE entries yet.
Need to ping the owners anyway, apparently.

In response to

Responses

pgsql-hackers by date

Next:From: Alvaro HerreraDate: 2009-07-02 15:35:02
Subject: Re: Upgrading our minimum required flex version for 8.5
Previous:From: Kevin GrittnerDate: 2009-07-02 15:27:57
Subject: Re: Upgrading our minimum required flex version for 8.5

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group