Skip site navigation (1) Skip section navigation (2)

Re: 8.3 build 603 build error on Fedora 8

From: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
To: Kris Jurka <books(at)ejurka(dot)com>
Cc: Devrim GÜNDÜZ <devrim(at)CommandPrompt(dot)com>, PostgreSQL - JDBC <pgsql-jdbc(at)postgresql(dot)org>
Subject: Re: 8.3 build 603 build error on Fedora 8
Date: 2008-02-12 17:07:27
Message-ID: 28833.1202836047@sss.pgh.pa.us (view raw or flat)
Thread:
Lists: pgsql-jdbc
Kris Jurka <books(at)ejurka(dot)com> writes:
> We determine which version of the driver to build based on the JVM we're 
> running in, so when I see this 
> "/usr/lib/jvm/java-1.7.0-icedtea-1.7.0.0/jre", I'm guessing it's reporting 
> itself as a 1.7 JVM while we only know about 1.6 and less.  Perhaps this 
> patch will help?

I'm not sure how Devrim got around it, but on my Fedora 8 machine this
patch is in fact necessary.  The 8.2 driver doesn't build without it
anymore, either (probably true all the way back, but 8.2 and 8.3 are
the only ones I tested).

			regards, tom lane

In response to

Responses

pgsql-jdbc by date

Next:From: Devrim GÜNDÜZDate: 2008-02-12 17:20:38
Subject: Re: 8.3 build 603 build error on Fedora 8
Previous:From: Jan de VisserDate: 2008-02-12 02:22:28
Subject: Re: Patch for Statement.getGeneratedKeys()

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group