Alvaro Herrera <alvherre(at)commandprompt(dot)com> writes:
> Tom Lane wrote:
>> Or we could get radical and rename both of them...
> Well, it is a bit misleading to have the query_string stuff be named
> "stats" when it's not actually collected by pgstats at all. Maybe
> rename it to "collect_query_string". With the other name being
> "collect_stats", they would show up together in SHOW ALL.
query_string is pretty misleading these days too, since pg_stat_activity
includes a lot more than the bare query string.
If we were doing this on a blank slate I would suggest "track_stats"
and "track_activities", but that might be too different from what
people are used to.
regards, tom lane
In response to
pgsql-hackers by date
|Next:||From: Bruce Momjian||Date: 2007-07-31 18:38:33|
|Subject: Re: default_text_search_config and expression
|Previous:||From: Oleg Bartunov||Date: 2007-07-31 18:28:26|
|Subject: Re: default_text_search_config and expression indexes|