Skip site navigation (1) Skip section navigation (2)

Re: [INTERFACES] PL_na undeclared

From: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
To: John Cusick <jcusick(at)exotrope(dot)net>
Cc: pgsql-interfaces(at)hub(dot)org
Subject: Re: [INTERFACES] PL_na undeclared
Date: 1999-09-27 23:52:15
Message-ID: 28025.938476335@sss.pgh.pa.us (view raw or flat)
Thread:
Lists: pgsql-interfaces
John Cusick <jcusick(at)exotrope(dot)net> writes:
> I patched the 6.5.1 source yesterday to 6.5.2 and when making the perl
> interface I get the following error:
> 'PL_na' undeclared (first use this function)
> throughout the make process.

We've heard reports of that before.  Apparently, the low-level
interfaces to Perl have changed incompatibly in the recent past
(between 5.004 something and 5.005 something I think).

We have been looking for a Perl guru who knows how to make Pg.pm
work under both older and newer Perls --- breaking back revs to
work with the latest doesn't seem particularly appealing :-(

Know any Perl gurus?

> My system is a Redhat5.1 based running 2.2.10 with updated glibc as well
> as perl 5.004.04.

Are you sure it's not 5.005 something?  5.004_04 is what I'm using here,
and it seems perfectly happy with the current Pg.pm.  The folks who
reported this error before were using bleeding-edge Perls...

			regards, tom lane

Responses

pgsql-interfaces by date

Next:From: Lamar OwenDate: 1999-09-28 00:07:58
Subject: Re: [INTERFACES] PL_na undeclared
Previous:From: Tim JoyceDate: 1999-09-27 21:25:26
Subject: psql trerminal behaviour

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group