Skip site navigation (1) Skip section navigation (2)

Re: DTrace probe patch for OS X Leopard

From: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
To: Robert Lor <Robert(dot)Lor(at)Sun(dot)COM>
Cc: Peter Eisentraut <peter_e(at)gmx(dot)net>, pgsql-patches(at)postgresql(dot)org
Subject: Re: DTrace probe patch for OS X Leopard
Date: 2008-02-29 16:03:13
Message-ID: 2791.1204300993@sss.pgh.pa.us (view raw or flat)
Thread:
Lists: pgsql-patches
Robert Lor <Robert(dot)Lor(at)Sun(dot)COM> writes:
> Peter Eisentraut wrote:
>> I understand that these probe names follow some global naming scheme.  Is it 
>> hard to change that?  I'd feel more comfortable with, say, 
>> (D)TRACE_POSTGRESQL_LWLOCK_ACQUIRE().
>> 
> Because the macro is auto generated and follows certain naming 
> conventions, prepending TRACE_ will not work. If you did that, the probe 
> name will be called "postgresql-lwlock-aquire" and the provider will be 
> "trace" which is not what we want.

Ugh.  Is this tool really so badly designed that it thinks it has
ownership of the *entire* namespace within the target program?

			regards, tom lane

In response to

pgsql-patches by date

Next:From: Robert LorDate: 2008-02-29 17:11:14
Subject: Re: DTrace probe patch for OS X Leopard
Previous:From: Tom LaneDate: 2008-02-29 16:01:40
Subject: Re: remove TCL_ARRAYS

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group