Skip site navigation (1) Skip section navigation (2)

Re: Bug #611: configure script produces incorrect results under IRIX

From: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
To: jp(at)celestrion(dot)net, pgsql-bugs(at)postgresql(dot)org
Subject: Re: Bug #611: configure script produces incorrect results under IRIX
Date: 2002-03-11 14:28:36
Message-ID: 26051.1015856916@sss.pgh.pa.us (view raw or flat)
Thread:
Lists: pgsql-bugs
pgsql-bugs(at)postgresql(dot)org writes:
> The root cause of this problem is that the script interpreter for the
> configure script is /bin/sh.  The configure script is NOT a /bin/sh
> compatible script.  It requires GNU BASH to execute properly.

Hardly, considering that I don't have GNU BASH installed at all here ;-)

There may well be something in the script that is not perfectly
portable, but if so, please tell us exactly what, so we can fix it.

"Use GNU BASH" is not a portable answer either --- we will most
certainly not put anything in the script to deliberately prevent it
from working on non-BASH shells.

			regards, tom lane

In response to

pgsql-bugs by date

Next:From: Yury BokhoncovichDate: 2002-03-11 14:33:30
Subject: Re:
Previous:From: Yury BokhoncovichDate: 2002-03-11 14:23:20
Subject: Re: Bug #608: cache lookup failed

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group