Skip site navigation (1) Skip section navigation (2)

cannot install postgresql 7.2

From: UltraMax <mcsim(at)dinamo-minsk(dot)com>
To: pgsql-bugs(at)postgresql(dot)org
Subject: cannot install postgresql 7.2
Date: 2002-03-01 10:26:25
Message-ID: 257379951.20020301122625@dinamo-minsk.com (view raw or flat)
Thread:
Lists: pgsql-bugs
Hello pgsql-bugs,

  I cannot install postgresql-7.2 on my Debian Linux
  I have downloaded postgresql-7.2.tar.gz from
  http://www.ca.postgresql.org/ftpsite/v7.2/postgresql-7.2.tar.gz and
  try to install on Debian linux 2.2 release 5
  Here is all info about system, that was get by the command "uname -a"
  Linux ws035 2.4.17 #3 Wed Feb 13 11:44:07 EET 2002 i686 unknown
  I make ./configure and then I run "gmake", but after several minutes
  I get next message

up_db.o pg_backup_custom.o pg_backup_files.o pg_backup_null.o pg_backup_tar.o -L../../../src/interfaces/libpq -lpq  -Wl,-rpath,/usr/local/pgsql/lib -lcrypt -lresolv -lnsl -ldl -lm  -o pg_dump
../../../src/interfaces/libpq/libpq.so: undefined reference to `atexit'
collect2: ld returned 1 exit status
gmake[3]: *** [pg_dump] Error 1
gmake[3]: Leaving directory `/test/postgresql-7.2/src/bin/pg_dump'
gmake[2]: *** [all] Error 2
gmake[2]: Leaving directory `/test/postgresql-7.2/src/bin'
gmake[1]: *** [all] Error 2
gmake[1]: Leaving directory `/test/postgresql-7.2/src'
gmake: *** [all] Error 2
ws035:/test/postgresql-7.2#

  while I expect to see "All of PostgreSQL is successfully made. Ready
  to install."
  I use GNU Make version 3.79.1, by Richard Stallman and Roland McGrath.
  When I do these things on machine with Mandrake Linux 8.1 -
  everything is OK. I got the mentioned above successful message. But
  I need to install PostgreSQl on Debian Linux.
  What should be done, to nevertheless install Postgre on Debian?
  
  
-- 
Best regards, looking forward to your answer
 UltraMax                          mailto:mcsim(at)dinamo-minsk(dot)com


Responses

pgsql-bugs by date

Next:From: UltraMaxDate: 2002-03-01 12:36:43
Subject: Re: cannot install postgresql 7.2
Previous:From: pgsql-bugsDate: 2002-03-01 09:50:26
Subject: Bug #605: timestamp(timestamp('a timestamp)) no longer works

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group