Skip site navigation (1) Skip section navigation (2)

Re: Psql malloc error on Git master

From: Bernd Helmle <mailings(at)oopsware(dot)de>
To: Thom Brown <thom(at)linux(dot)com>, Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
Cc: pgsql-bugs <pgsql-bugs(at)postgresql(dot)org>
Subject: Re: Psql malloc error on Git master
Date: 2011-01-21 14:55:53
Message-ID: 24DCA0F12595965A123C2DEF@amenophis (view raw or flat)
Thread:
Lists: pgsql-bugs

--On 20. Januar 2011 21:56:44 +0000 Thom Brown <thom(at)linux(dot)com> wrote:

>> Known bug in OSX's libedit.  Use readline instead.
>>
>> http://archives.postgresql.org/pgsql-bugs/2010-04/msg00127.php
>>
>>                        regards, tom lane
>
> How do I force readline?  I'm not using --with-libedit-preferred or
> --without-readline

What I've done is to switch to MacPorts[1] and use their packaging. I'm 
building PostgreSQL then with:

--with-libraries=/opt/local/lib --with-includes=/opt/local/include

which for example links psql/libreadline with:

% otool -L $PGSQL_HOME/bin/psql
/Users/bernd/pgsql-dev/install/HEAD/bin/psql:
	/Users/bernd/pgsql-dev/install/HEAD/lib/libpq.5.dylib (compatibility 
version 5.0.0, current version 5.4.0)
	/opt/local/lib/libintl.8.dylib (compatibility version 10.0.0, current 
version 10.1.0)
	/opt/local/lib/libssl.1.0.0.dylib (compatibility version 1.0.0, current 
version 1.0.0)
	/opt/local/lib/libreadline.6.1.dylib (compatibility version 6.0.0, current 
version 6.1.0)

Works quite well for me. There's also a libedit in MacPorts, but i've never 
used it.

        Bernd

[1] <http://www.macports.org/>


In response to

Responses

pgsql-bugs by date

Next:From: Andrew DunstanDate: 2011-01-21 15:24:46
Subject: Re: Is there a way to build PostgreSQL client libraries with MinGW
Previous:From: Magnus HaganderDate: 2011-01-21 10:24:02
Subject: Re: Is there a way to build PostgreSQL client libraries with MinGW

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group