Skip site navigation (1) Skip section navigation (2)

Re: BUG #1126: TCP Connection Issues.

From: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
To: "Paul Bone" <boney(at)digitalerection(dot)com>
Cc: pgsql-bugs(at)postgresql(dot)org
Subject: Re: BUG #1126: TCP Connection Issues.
Date: 2004-04-04 16:28:49
Message-ID: 24788.1081096129@sss.pgh.pa.us (view raw or flat)
Thread:
Lists: pgsql-bugs
"PostgreSQL Bugs List" <pgsql-bugs(at)postgresql(dot)org> writes:
> When connecting with TCP the backend server process "spins" in mallopt (from 
> /lib/tls/libc) 

You seem to have a rather badly broken build :-(.  Did you compile it
yourself or get it from someone else?  If the latter, you need to
complain to the someone else.

If you built Postgres yourself then you need to take another look at the
build process.  I am guessing that something is wrong with the configure
script's results relating to HAVE_STRUCT_ADDRINFO and HAVE_GETADDRINFO,
but it's hard to tell just what.  If you made more than one try at
getting the configuration options right, you might just need to do a
pristine build with the correct options set --- changing options in a
partially complete build tree is risky.

			regards, tom lane

In response to

pgsql-bugs by date

Next:From: Johan DuflostDate: 2004-04-05 10:08:10
Subject: Bug #641: LIBPQ Linking with the static library on the WIN32 platform fails connections with "unknown host name".
Previous:From: PostgreSQL Bugs ListDate: 2004-04-04 15:02:13
Subject: BUG #1126: TCP Connection Issues.

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group