Skip site navigation (1) Skip section navigation (2)

pgadmin 3 on Debian Stable (woody)

From: "Derek Neighbors" <derek(at)gnue(dot)org>
To: <pgadmin-support(at)postgresql(dot)org>
Subject: pgadmin 3 on Debian Stable (woody)
Date: 2004-03-03 17:10:11
Message-ID: 22578.156.42.68.23.1078333811.squirrel@usahoteljobs.com (view raw or flat)
Thread:
Lists: pgadmin-support
Yesterday I went to the downloads section of http://pgadmin.postgresql.org
to pick up more current binaries for a user that only has windows.  I was
pleasantly suprised to notice that pgadmin has now been packaged for
GNU/Linux distributions including Debian.

I added the necessary line to my sources.list and performed the install. 
The install went fine, but please note there is a minor omission on the
website.

Note that the web site reads:

 For example, for France, you can try:

    * For Debian WOODY:
      ftp://ftp2.fr.postgresql.org/postgresql/pgadmin3/release/debian
woody pgadmin

    * For Debian TESTING:
      deb ftp://ftp2.fr.postgresql.org/postgresql/pgadmin3/release/debian
testing pgadmin

    * For Debian UNSTABLE:
      deb ftp://ftp2.fr.postgresql.org/postgresql/pgadmin3/release/debian
unstable pgadmin


It should read:

 For example, for France, you can try:

    * For Debian WOODY:
      deb ftp://ftp2.fr.postgresql.org/postgresql/pgadmin3/release/debian
woody pgadmin

    * For Debian TESTING:
      deb ftp://ftp2.fr.postgresql.org/postgresql/pgadmin3/release/debian
testing pgadmin

    * For Debian UNSTABLE:
      deb ftp://ftp2.fr.postgresql.org/postgresql/pgadmin3/release/debian
unstable pgadmin


Diff would be:

-       ftp://ftp2.fr.postgresql.org/postgresql/pgadmin3/release/debian
woody pgadmin
+       deb
ftp://ftp2.fr.postgresql.org/postgresql/pgadmin3/release/debian woody
pgadmin


Anyhow I went to run the application and got the following error:

An Error has occured:
Error connecting to the server: The PostgreSQL server must be at least
version 7.3!

The issue is Debian Stable (woody) has PostgreSQL server 7.2.  I think
there are a few ways to tackle this in packaging.

1. Include backports for 7.3 in the same repository that the pgadmin3
stuff is and "require" it as part ofinstalling pgadmin3

2. Make pgadmin3 work against current PostgreSQL packaging for Debian
Stable (Woody)

I personally would like to see #2 as I'm not in a position currently to
readily upgrade to 7.3. :)

Derek Neighbors
GNU Enterprise
http://www.gnuenterprise.org
derek(at)gnue(dot)org



Responses

pgadmin-support by date

Next:From: Andreas PflugDate: 2004-03-04 10:08:37
Subject: Re: pgadmin 3 on Debian Stable (woody)
Previous:From: kedar_hukeriDate: 2004-03-01 05:38:36
Subject: Enter your Birthday

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group