Skip site navigation (1) Skip section navigation (2)

Re: problem with WAL files

From: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
To: Jeff Frost <jeff(at)frostconsultingllc(dot)com>
Cc: pgsql-admin(at)postgresql(dot)org
Subject: Re: problem with WAL files
Date: 2005-06-30 22:48:17
Message-ID: 22553.1120171697@sss.pgh.pa.us (view raw or flat)
Thread:
Lists: pgsql-admin
Jeff Frost <jeff(at)frostconsultingllc(dot)com> writes:
> I'll have to retest that particular scenario and verify that something
> else was not causing the problem when I have a chance now that I have
> a fully functional and scripted out base backup and recover solution;
> however, it did not give me any of the errors I see when my
> walrestore.sh script cannot access an archived wal, so I would believe
> it did not even try to get it out of the archive.

As far as I can see from the code, it *should* try to get it out of
the archive ... and I'm quite sure we tested that case during 8.0
development ... so I suspect there is some other contributing factor in
your configuration.  If you could put together a self-contained test
case I'd be happy to dig into it, because it sounds like a bug to me.

			regards, tom lane

In response to

Responses

pgsql-admin by date

Next:From: jehan procacciaDate: 2005-07-01 09:07:06
Subject: Re: restore database from bare files
Previous:From: Jeff FrostDate: 2005-06-30 22:40:03
Subject: Re: problem with WAL files

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group