Skip site navigation (1) Skip section navigation (2)

Re: Compiling PgAdmin 1.8.x on Debian Lenny AMD64 ?

From: Raphaël Enrici <raphael(at)pgadmin(dot)org>
To: "Joost Kraaijeveld" <J(dot)Kraaijeveld(at)askesis(dot)nl>
Cc: pgadmin-support(at)postgresql(dot)org
Subject: Re: Compiling PgAdmin 1.8.x on Debian Lenny AMD64 ?
Date: 2008-02-15 10:58:26
Message-ID: 21e470ef0802150258g489a7c48od94f862da9558b9d@mail.gmail.com (view raw or flat)
Thread:
Lists: pgadmin-support
Hi Joost,
take an example from deb sources packages already published.

Download these three files:

ftp://ftp.fr.postgresql.org/pgadmin3/release/debian/dists/etch/pgadmin/source/misc/pgadmin3_1.8.0-1~pgaoetch1.diff.gz

ftp://ftp.fr.postgresql.org/pgadmin3/release/debian/dists/etch/pgadmin/source/misc/pgadmin3_1.8.0-1~pgaoetch1.dsc

ftp://ftp.fr.postgresql.org/pgadmin3/release/debian/dists/etch/pgadmin/source/misc/pgadmin3_1.8.0.orig.tar.gz


then dpkg-source -x *.dsc


copy the pgadmin3-1.8.0/debian to the upstream source directory (it should
be in a directory untitled pgadmin3-1.8.2)

then cd pgadmin3-1.8.2

type dch -i to add a changelog entry and modify the version number to
something like 1.8.2-xxx

then dpkg-buildpackage  -rfakeroot


it should build quite straightforward.


I know I'm late in releasing the package of 1.8.2 and I'm sorry about that.


Regards,

Raphaël



On 15/02/2008, Joost Kraaijeveld <J(dot)Kraaijeveld(at)askesis(dot)nl> wrote:
>
> Hi,
>
> I tried to compile the source distribution on Debian Lenny AMD64 to
> create a Debian package, which failed.
>
> Running "dpkg-buildpackage -rfakeroot" in the root of the source
> distribution gave the following error:
>
> "dpkg-buildpackage -rfakeroot
> tail: cannot open `debian/changelog' for reading: No such file or
> directory
> dpkg-buildpackage: failure: tail of debian/changelog gave error exit
> status 1"
>
>
> Running "dpkg-buildpackage -rfakeroot" in the pkg directory  of the
> source distribution errors that suggested that there should be a
> wxWidgets 2.7.0-1 source (?) installation somewhere in the PgAdmin
> source tree, which is not the case.
>
> I have a (compiled) version of wxWidgets 2.8.0 installed from a
> repository maintained by the wxWidgets people (http://apt.wxwidgets.org/
> etch-wx main).
>
> Is it possible to build a .deb file from the source distribution, using
> my own version of wxWidgets or do I have to fall back to "./configure ;
> make make install"?
>
> TIA
>
>
> --
> Groeten,
>
> Joost Kraaijeveld
> Askesis B.V.
> Molukkenstraat 14
> 6524NB Nijmegen
> tel: 024-3888063 / 06-51855277
> fax: 024-3608416
> web: www.askesis.nl
>
>
> ---------------------------(end of broadcast)---------------------------
> TIP 1: if posting/reading through Usenet, please send an appropriate
>        subscribe-nomail command to majordomo(at)postgresql(dot)org so that your
>        message can get through to the mailing list cleanly
>

In response to

Responses

pgadmin-support by date

Next:From: Joost KraaijeveldDate: 2008-02-15 13:33:26
Subject: Re: Compiling PgAdmin 1.8.x on Debian LennyAMD64 ?
Previous:From: Joost KraaijeveldDate: 2008-02-15 08:30:44
Subject: Compiling PgAdmin 1.8.x on Debian Lenny AMD64 ?

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group