Skip site navigation (1) Skip section navigation (2)

Re: Actualizar 8.0.1 a 8.0.3

From: Mario Gonzalez <gonzalemario(at)gmail(dot)com>
To: pgsql-es-ayuda(at)postgresql(dot)org
Subject: Re: Actualizar 8.0.1 a 8.0.3
Date: 2005-10-20 12:22:03
Message-ID: 2065a6cf0510200522x23bf9439h@mail.gmail.com (view raw or flat)
Thread:
Lists: pgsql-es-ayuda
On 19/10/05, dario_d_s(at)unitech(dot)com(dot)ar <dario_d_s(at)unitech(dot)com(dot)ar> wrote:
> Estimado:
>    Usualmente cuando se actualiza la sub sub versión (de 8.0._1_ a 8.0._3_) no debe hacerse mucho más (no uso gentoo, lo hice con rpms y funciona lo más bien). Pero en este caso en particular de la actualizaciòn 8.0.3, sería necesario que hagas un dump y restore para poder aplicar correctamente la versiòn (lo dijo Tom en la lista en inglés). Buscá el change log de la versión 8.0.3. Si no lo hacés, tenés que arreglarlo a mano. http://www.postgresql.org/docs/8.0/static/release-8-0-3.html para màs datos.
>    Como tenés que parar el motor, a lo mejor podés hacer un backup en frio antes del update de versión. Con eso si llega a pasar algo volvés para atras cualquier cambio.
>
>
  Hola, saben yo tengo un comentario un poco distinto, quizas me
quieran linchar despues pero....

    No he visto aun las diferencias entre la 8.0_1 y la 8.0_3  y
quizas no sean muchas. De manera de que si tu estas bien con la base
de datos actual y no necesitas otras funcionallidades, bueno, yo me
quedaria con la primera y no realizaria el update. Lo digo a base de
experiencia, ademas como tu dices que tienes la DB ya funcionando con
usuarios y mas cuando la decision que tomes puede costarte el
"pellejo". Como administrador no puedes darte el lujo de hacer
"pruebas" en produccion o en ambientes coorporativos. Creo que cuando
hay que actualizar de manera obligatoria es cuando se encuentra algun
error de seguridad o problemas en la DB que puedan dejar
inconsistencias en tus datos. Por ejemplo, yo uso Debian y
Postgresql7.4 y hasta ahora no he necesitado mas  y anda muy bien.  Lo
que yo haria es tener una maquina similar y trataria de simular el
mismo cambio para ver que pasa con mis propios ojos.

  Pero claro, es solo mi opinion personal; )  Saludos!

>
> Miguel wrote ..
> > Hola, segun he leido para actualizar de una version o revision menor a
> > una mayor  de postgres se debe hacer  con un pg_dump primero, yo tengo
> > en gentoo la version 8.0.1 , el directorio data lo monto en un array
> > externo, estoy instalando un nuevo servidor y ahora la ultima version de
> > postgres en el portage de gentoo es 8.0.3, habra algun peligro de
> > corrupcion de datos si instalo la nueva version en el nuevo server y
> > simplemente monto el viejo directorio data?, en teoria deberia funcionar
> > no?, por supuesto tengo backups, y tampoco quisiera hacer el pg_dump ya
> > que se lleva varias horas, igual recuperar de las cintas y estaria el
> > servicio demasiado tiempo fuera, yo le he comentado a mi jefe que no
> > deberia haber problema, el unico tiempo fuera deberia ser mientras se
> > detiene posrgres, se desmonta el directorio data en el viejo server , se
> > monta en el nuevo y se inicia postgres, me gustaria estar seguro de que
> > funciona, recuerden que mi pellejo estaria en juego, algun comentario si
> > alguien ya hizo algo similar?
>

In response to

Responses

pgsql-es-ayuda by date

Next:From: Luis GuevaraDate: 2005-10-20 13:45:36
Subject: Recuperar registro Borrado
Previous:From: diego ayala torresDate: 2005-10-20 10:43:25
Subject: Warning del vacuum

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group