Skip site navigation (1) Skip section navigation (2)

Re: pkg-config files for libpq and ecpg

From: Michael Meskes <meskes(at)postgresql(dot)org>
To: Peter Eisentraut <peter_e(at)gmx(dot)net>
Cc: pgsql-hackers <pgsql-hackers(at)postgresql(dot)org>
Subject: Re: pkg-config files for libpq and ecpg
Date: 2013-01-16 14:16:55
Message-ID: 20130116141655.GA17295@feivel.credativ.lan (view raw or flat)
Thread:
Lists: pgsql-hackers
On Tue, Jan 15, 2013 at 02:16:01PM -0500, Peter Eisentraut wrote:
> A side issue that arose: libecpg_compat is linked with libpq, but
> doesn't seem to use it.  This was added many years ago in
> cd75f94dafd43358305811b7576ad75d889097e3, but it doesn't appear to be
> required anymore.  Needs some checking.

libecpg_compat doesn't directly need libpq IIRC, but it does indirectly There
are a couple functions from libecpg that are used in libecpg_compat and libecpg
itself does need libpq.

Michael

-- 
Michael Meskes
Michael at Fam-Meskes dot De, Michael at Meskes dot (De|Com|Net|Org)
Michael at BorussiaFan dot De, Meskes at (Debian|Postgresql) dot Org
Jabber: michael.meskes at gmail dot com
VfL Borussia! Força Barça! Go SF 49ers! Use Debian GNU/Linux, PostgreSQL


In response to

pgsql-hackers by date

Next:From: Stephen FrostDate: 2013-01-16 14:17:54
Subject: Re: CF3+4
Previous:From: Craig RingerDate: 2013-01-16 14:16:33
Subject: Re: CF3+4 (was Re: Parallel query execution)

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group