Skip site navigation (1) Skip section navigation (2)

Re: pg_upgrade with postgis

From: Bruce Momjian <bruce(at)momjian(dot)us>
To: Ronit Allen <ronit(dot)allen(at)gmail(dot)com>
Cc: pgsql-admin(at)postgresql(dot)org
Subject: Re: pg_upgrade with postgis
Date: 2012-09-13 04:02:44
Message-ID: 20120913040244.GA18423@momjian.us (view raw or flat)
Thread:
Lists: pgsql-admin
On Thu, Sep 13, 2012 at 02:12:40AM +0300, Ronit Allen wrote:
> Hi -
>  
> Thanks.
> As we installed using pg repos (yum) I don't think it will allow me to
> re-install postgis.
> Is it possible to specify a target cluster for a postgis install from repo or
> will it need to be installed from source?

You just need to have a valid data directory and binaries --- you don't
need source.

---------------------------------------------------------------------------


> Thanks again.
> On Wed, Sep 12, 2012 at 1:17 AM, Bruce Momjian <bruce(at)momjian(dot)us> wrote:
> 
>     On Tue, Sep 11, 2012 at 04:15:31PM +0300, Ronit Allen wrote:
>     > HI -
>     >
>     > I am looking to upgrade our postgresql 9 to 9,2 using pg_upgrade.
>     >
>     > We have postgis installed on the current cluster (9).
>     >
>     > Both postgresql and postgis was installed using the pg repos.
>     >
>     > Will I need to re-install postgis after running pg_upgrade?
> 
>     You will need to have all plug-in stuff installed in the new
>     cluster before running pg_upgrade.  You should then be able to run
>     pg_upgrade and all your postgis data will be migrated.
> 
>     --
>       Bruce Momjian  <bruce(at)momjian(dot)us>        http://momjian.us
>       EnterpriseDB                             http://enterprisedb.com
> 
>       + It's impossible for everything to be true. +
> 
> 

-- 
  Bruce Momjian  <bruce(at)momjian(dot)us>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com

  + It's impossible for everything to be true. +


In response to

pgsql-admin by date

Next:From: johnkn63Date: 2012-09-13 08:04:44
Subject: non-superuser login phpPgAdmin PostgreSQL 9.1
Previous:From: Kevin GrittnerDate: 2012-09-13 03:13:38
Subject: Re: what is maximum allowed value of autovacuum_freeze_max_age

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group