Skip site navigation (1) Skip section navigation (2)

Re: Upgrading from 9.1.2 to 9.1.5

From: Bruce Momjian <bruce(at)momjian(dot)us>
To: Kevin Grittner <Kevin(dot)Grittner(at)wicourts(dot)gov>
Cc: Craig James <cjames(at)emolecules(dot)com>, pgsql-admin(at)postgresql(dot)org
Subject: Re: Upgrading from 9.1.2 to 9.1.5
Date: 2012-09-10 19:56:15
Message-ID: 20120910195615.GA15844@momjian.us (view raw or flat)
Thread:
Lists: pgsql-admin
On Mon, Sep 10, 2012 at 12:06:10PM -0500, Kevin Grittner wrote:
> Craig James <cjames(at)emolecules(dot)com> wrote:
> > Sergey Konoplev <gray(dot)ru(at)gmail(dot)com> wrote:
> >> Bruce Momjian <bruce(at)momjian(dot)us> wrote:
> >>> On Thu, Sep  6, 2012 at 05:55:05PM -0500, Antoine Guidi wrote:
> >>>> Is it possible to do a pg_upgrade from 9.1.2 to 9.1.5 just
> >>>> using pg_upgrade?  For what I could read, the only exception
> >>>> would be if I was using a citext column (which I am not).
> >>>
> >>> You cannot use pg_upgrade for this.
>  
> "Cannot" or "don't need to"?

Cannot.  The tablespace directory names have the same embedded system
catalog version for minor releases of the same major version.

-- 
  Bruce Momjian  <bruce(at)momjian(dot)us>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com

  + It's impossible for everything to be true. +


In response to

pgsql-admin by date

Next:From: David MortonDate: 2012-09-10 20:30:59
Subject: Large historical tables and autovacuum
Previous:From: Antoine GuidiDate: 2012-09-10 17:45:34
Subject: Re: Upgrading from 9.1.2 to 9.1.5

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group