Skip site navigation (1) Skip section navigation (2)

BUG #6305: cann't reinstall postgresql

From: "nadhiya" <nadhiyacse07(at)gmail(dot)com>
To: pgsql-bugs(at)postgresql(dot)org
Subject: BUG #6305: cann't reinstall postgresql
Date: 2011-11-23 06:02:05
Message-ID: 201111230602.pAN625FK059405@wwwmaster.postgresql.org (view raw or flat)
Thread:
Lists: pgsql-bugs
The following bug has been logged online:

Bug reference:      6305
Logged by:          nadhiya
Email address:      nadhiyacse07(at)gmail(dot)com
PostgreSQL version: 8.4
Operating system:   ubuntu 10.04
Description:        cann't reinstall postgresql
Details: 

i installed openerpV6.0.3 server and client i worked on that but suddenly i
cannot connect with the postgres,i got cannot access server.key,after that i
changed file permissions and private key.but no one is work.

now i remove and reinstall postgres

i got dpkg error always while using sudo apt - get command.

i used  most of the way we mentioned in the documentation but i can't solve
this.

please help me to solve this problem i spent more than 2 days.  

error:   
ubuntu(at)ubuntu-laptop:~$ sudo apt-get install
[sudo] password for ubuntu: 
Sorry, try again.
[sudo] password for ubuntu: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Setting up postgresql-8.4 (8.4.9-0ubuntu0.10.04) ...
 * Starting PostgreSQL 8.4 database server                                  
    * Error: could not exec /usr/lib/postgresql/8.4/bin/pg_ctl
/usr/lib/postgresql/8.4/bin/pg_ctl start -D /var/lib/postgresql/8.4/main -l
/var/log/postgresql/postgresql-8.4-main.log -s -o  -c
config_file="/etc/postgresql/8.4/main/postgresql.conf" : 
                                                                        
[fail]
invoke-rc.d: initscript postgresql-8.4, action "start" failed.
dpkg: error processing postgresql-8.4 (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of postgresql:
 postgresql depends on postgresql-8.4; however:
  Package postgresql-8.4 is not configured yet.
dpkg: error processing postgresql (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup
error from a previous failure.
                          Errors were encountered while processing:
 postgresql-8.4
 postgresql
E: Sub-process /usr/bin/dpkg returned an error code (1)

Responses

pgsql-bugs by date

Next:From: Marco BernasocchiDate: 2011-11-23 11:07:05
Subject: libpq in android
Previous:From: Robert HaasDate: 2011-11-23 02:49:48
Subject: Re: BUG #6300: duplicate key value violates unique constraint

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group