Skip site navigation (1) Skip section navigation (2)

RE: [Probable Correo Basura] Re: urgente!!! restore

From: "Gustavo Rosso" <grosso(at)sadaic(dot)org(dot)ar>
To: "'Mario Sileone'" <msileone(at)easymail(dot)net(dot)ar>
Cc: "'Miguel Angel Hernandez Moreno'" <miguel(dot)hdz(dot)mrn(at)gmail(dot)com>,"'pgsql-es-ayuda'" <pgsql-es-ayuda(at)postgresql(dot)org>
Subject: RE: [Probable Correo Basura] Re: urgente!!! restore
Date: 2011-05-27 16:40:50
Message-ID: 20110527164139.504301E18460@mail.sadaic.org.ar (view raw or flat)
Thread:
Lists: pgsql-es-ayuda

-----Mensaje original-----
De: pgsql-es-ayuda-owner(at)postgresql(dot)org
[mailto:pgsql-es-ayuda-owner(at)postgresql(dot)org] En nombre de Mario Sileone
Enviado el: Viernes, 27 de Mayo de 2011 01:26 p.m.
Para: Gustavo Rosso
CC: 'Miguel Angel Hernandez Moreno'; 'pgsql-es-ayuda'
Asunto: Re: [Probable Correo Basura] Re: [pgsql-es-ayuda] urgente!!! restore


El 27/05/2011 13:20, Gustavo Rosso escribió:
>
> Si!!!
>
> version origen
>
> PostgreSQL 8.3.7 on i686-pc-linux-gnu, compiled by GCC gcc (Debian 
> 4.4.5-8) 4.4.5
>
> Nueva version instalada
>
> PostgreSQL 8.3.7 on i686-pc-linux-gnu, compiled by GCC gcc (Debian 
> 4.3.2-1.1) 4.3.2
>
> ------------------------------------------------------------------------
>
> *De:*Miguel Angel Hernandez Moreno [mailto:miguel(dot)hdz(dot)mrn(at)gmail(dot)com]
> *Enviado el:* Viernes, 27 de Mayo de 2011 01:05 p.m.
> *Para:* Gustavo Rosso
> *CC:* pgsql-es-ayuda
> *Asunto:* [Probable Correo Basura] Re: [pgsql-es-ayuda] urgente!!! restore
> *Importancia:* Baja
>
> es la misma version??
>
> 2011/5/27 Gustavo Rosso <grosso(at)sadaic(dot)org(dot)ar 
> <mailto:grosso(at)sadaic(dot)org(dot)ar>>
>
> Buen dia.
>
> Instale nuevamente postgresql en otro equipo.
>
> Instale las librerias libperl-dev, zlib1-dev
>
> Ejecuto
>
> ./configure --with-perl --without-readline --with-zlib
>
> Make
>
> Make install
>
> Arranco y todo funciona bien, creo la base de datos con un esquema 
> importado que se corresponde con los datos a levantar.
>
> Cuando quiero hacer el restore de la base de datos ejecuto:
>
> pg_restore -a -v -e -Fc -O -disable-triggers -d banco 
> /home/backup/banco.data
>
> y me da el siguiente error:
>
> pg_restore: [archiver] WARNING: archive is compressed, but this 
> installation does not support compression -- no data will be available
>
> pg_restore: [archiver] cannot restore from compressed archive 
> (compression not supported in this installation)
>
> pg_restore: *** aborted because of error
>
> Si tengo la libreria zlib instalada, porque sucede esto?
>
> Muchas gracias por lo que puedan ayudarme.
>
> Gustavo
>
>
>
>
> -- 
> ISC Miguel Angel Hernandez Moreno
>
> Puedes pegar la parte del configure que hace referencia a zlib para ver 
> si hubo problemas en la compilación?


Hola, esto es lo que veo de zlib en el config.log, no se si es exactamente
lo que me pedis.

It was created by PostgreSQL configure 8.3.7, which was
generated by GNU Autoconf 2.59.  Invocation command line was

  $ ./configure --with-perl --without-readline --with-zlib

configure:10361: checking zlib.h usability
configure:10406: checking zlib.h presence
configure:10477: checking for zlib.h	
configure:10484: result: yes

ac_cv_header_zlib_h=yes
with_zlib='yes'


In response to

pgsql-es-ayuda by date

Next:From: Julio AvilaDate: 2011-05-27 16:51:32
Subject: Numerar filas
Previous:From: Mario SileoneDate: 2011-05-27 16:26:22
Subject: Re: [Probable Correo Basura] Re: urgente!!! restore

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group