Skip site navigation (1) Skip section navigation (2)

Re: pg_upgrade issues

From: Bruce Momjian <bruce(at)momjian(dot)us>
To: depstein(at)alliedtesting(dot)com
Cc: pgsql-bugs(at)postgresql(dot)org, pgagarinov(at)alliedtesting(dot)com
Subject: Re: pg_upgrade issues
Date: 2010-07-09 16:59:26
Message-ID: 201007091659.o69GxQS10895@momjian.us (view raw or flat)
Thread:
Lists: pgsql-bugs
depstein(at)alliedtesting(dot)com wrote:
> Encountered another problem with pg_upgrade on Windows XP Pro:
> 
> I was trying to migrate from 8.4 to 9.0beta2 without linking, and
> apparently there was not enough space on the hard drive. However,
> pg_upgrade didn't report any problems, and it looked for all the world
> as if everything went well. I only found out that not all files were
> copied to the new cluster when vacuumdb reported missing files and when
> I actually compared the sizes of the two clusters on the disk.

Thank you for the clear bug report.  Magnus has diagnosed the problem,
and I am attaching the patch fix that will appear in 9.0 beta4. 
Fortunately this problem only happens in copy mode, and only when the
copy fails, as you saw.

--
  Bruce Momjian  <bruce(at)momjian(dot)us>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com

  + None of us is going to be here forever. +

Attachment: /rtmp/diff
Description: text/x-diff (1.2 KB)

In response to

pgsql-bugs by date

Next:From: Magnus HaganderDate: 2010-07-09 17:17:59
Subject: Re: [TESTERS] Location of certs -Windows 7 SSL mode?
Previous:From: Tom LaneDate: 2010-07-09 14:53:36
Subject: Re: BUG #5549: Feature: plpgsql should allow DECLARE cursor FOR EXECUTE '...'

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group