Skip site navigation (1) Skip section navigation (2)

Re: No lidbl.so in libpq.so (postgresql 8.4.4)

From: Tatsuo Ishii <ishii(at)postgresql(dot)org>
To: lists(at)itech7(dot)com
Cc: gfu(at)sigmaspace(dot)com, pgsql-general(at)postgresql(dot)org
Subject: Re: No lidbl.so in libpq.so (postgresql 8.4.4)
Date: 2010-05-28 17:06:02
Message-ID: 20100529.020602.34553129.t-ishii@sraoss.co.jp (view raw or flat)
Thread:
Lists: pgsql-general
> On Fri, May 28, 2010 at 10:13 PM, Gary Fu <gfu(at)sigmaspace(dot)com> wrote:
> > Nilesh Govindarajan wrote:
> >>
> >> On Tue, May 25, 2010 at 7:48 PM, Gary Fu <gary(dot)fu(at)sigmaspace(dot)com> wrote:
> >>
> >>>
> >>> Hi,
> >>>
> >>> On my mandriva linux, I don't have problem to build pgpool 2.3.3 with
> >>> postgresql 8.4.2.  But when I upgraded to 8.4.4, I cannot build pgpool
> >>> again
> >>> due to the libdl.so is not required in libpq.so (from the ldd command).
> >>>  Do
> >>> you know how to build the 8.4.4 so that libdl.so is required in libpq.so
> >>> ?
> >>>
> >>> 10:16am 32 gfu(at)nppdist:~/postgres/postgresql-8.4.4> locate libdl
> >>> /lib/libdl-2.6.1.so
> >>> /lib/libdl.so.2
> >>>
> >>> 10:16am 33 gfu(at)nppdist:~/postgres/postgresql-8.4.4> ldd
> >>> ./src/interfaces/libpq/libpq.so
> >>>       linux-gate.so.1 =>  (0xffffe000)
> >>>       libcrypt.so.1 => /lib/libcrypt.so.1 (0x40026000)
> >>>       libc.so.6 => /lib/i686/libc.so.6 (0x40054000)
> >>>       /lib/ld-linux.so.2 (0x80000000)
> >>>
> >>>
> >>> Thanks,
> >>> Gary
> >>>
> >>> --
> >>> Sent via pgsql-general mailing list (pgsql-general(at)postgresql(dot)org)
> >>> To make changes to your subscription:
> >>> http://www.postgresql.org/mailpref/pgsql-general
> >>>
> >>>
> >>
> >>
> >> Could you please explain a little more what you want to do actually ?
> >>
> >>
> >
> > I have the following problem to run 'configure' when building pgpool 2.3.3
> > with libpq from normal built of postgreSQL 8.4.4.
> >
> > configure:24789: result: no
> > configure:24799: error: libpq is not installed or libpq is old
> >
> >
> > However, when I rebuilt the 8.4.4 with 'LDFLAGS='-ldl' during configure, I
> > don't have problem to build pgpool 2.3.3.

He didn't have problem with PostgreSQL 8.4.2+pgpool-II 2.3.3 and he's
wondering why he now starts to have a problem with 8.4.4, I think.
--
Tatsuo Ishii
SRA OSS, Inc. Japan
English: http://www.sraoss.co.jp/index_en.php
Japanese: http://www.sraoss.co.jp

In response to

pgsql-general by date

Next:From: Jignesh ShahDate: 2010-05-28 17:20:29
Subject: cannot use column references in default expression?
Previous:From: Nilesh GovindarajanDate: 2010-05-28 16:56:58
Subject: Re: No lidbl.so in libpq.so (postgresql 8.4.4)

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group