Skip site navigation (1) Skip section navigation (2)

Re: BUG #5339: Version of Perl detected incorrectly

From: Tim Bunce <Tim(dot)Bunce(at)pobox(dot)com>
To: Jonathan Duke Leto <jonathan(at)leto(dot)net>
Cc: pgsql-bugs(at)postgresql(dot)org
Subject: Re: BUG #5339: Version of Perl detected incorrectly
Date: 2010-02-22 20:05:16
Message-ID: 20100222200516.GG1018@timac.local (view raw or flat)
Thread:
Lists: pgsql-bugs
Using
        perl -e 'use 5.008010'

would be a more reliable way for configure to test the perl version.

Tim.

On Mon, Feb 22, 2010 at 05:57:56PM +0000, Jonathan Duke Leto wrote:
> 
> The following bug has been logged online:
> 
> Bug reference:      5339
> Logged by:          Jonathan "Duke" Leto
> Email address:      jonathan(at)leto(dot)net
> PostgreSQL version: master 0f50d482
> Operating system:   CentOS 5.4 (Linux kernel 2.6.18)
> Description:        Version of Perl detected incorrectly
> Details: 
> 
> $  perl -v
> 
> This is perl 5, version 11, subversion 4 (v5.11.4-114-ga4cc961*) built for
> x86_64-linux
> 
> checking build system type... x86_64-unknown-linux-gnu
> checking host system type... x86_64-unknown-linux-gnu
> checking which template to use... linux
> checking whether to build with 64-bit integer date/time support... yes
> checking whether NLS is wanted... no
> checking for default port number... 5432
> checking for block size... 8kB
> checking for segment size... 1GB
> checking for WAL block size... 8kB
> checking for WAL segment size... 16MB
> checking for gcc... gcc
> checking for C compiler default output file name... a.out
> checking whether the C compiler works... yes
> checking whether we are cross compiling... no
> checking for suffix of executables... 
> checking for suffix of object files... o
> checking whether we are using the GNU C compiler... yes
> checking whether gcc accepts -g... yes
> checking for gcc option to accept ISO C89... none needed
> checking if gcc supports -Wdeclaration-after-statement... yes
> checking if gcc supports -Wendif-labels... yes
> checking if gcc supports -fno-strict-aliasing... yes
> checking if gcc supports -fwrapv... yes
> checking whether the C compiler still works... yes
> checking how to run the C preprocessor... gcc -E
> checking allow thread-safe client libraries... yes
> checking whether to build with Tcl... no
> checking whether to build Perl modules... no
> checking whether to build Python modules... no
> checking whether to build with GSSAPI support... no
> checking whether to build with Kerberos 5 support... no
> checking whether to build with PAM support... no
> checking whether to build with LDAP support... no
> checking whether to build with Bonjour support... no
> checking whether to build with OpenSSL support... no
> checking for grep that handles long lines and -e... /bin/grep
> checking for egrep... /bin/grep -E
> checking for ld used by GCC... /usr/bin/ld
> checking if the linker (/usr/bin/ld) is GNU ld... yes
> checking for ranlib... ranlib
> checking for strip... strip
> checking whether it is possible to strip libraries... yes
> checking for ar... ar
> checking for tar... /bin/tar
> checking whether ln -s works... yes
> checking for gawk... gawk
> checking for a thread-safe mkdir -p... /bin/mkdir -p
> checking for bison... /usr/bin/bison
> configure: using bison (GNU Bison) 2.3
> checking for flex... configure: WARNING:
> *** The installed version of Flex, /usr/bin/flex, is too old to use with
> PostgreSQL.
> *** Flex version 2.5.31 or later is required, but this is /usr/bin/flex
> version 2.5.4.
> configure: WARNING:
> *** The installed version of Flex, /usr/bin/lex, is too old to use with
> PostgreSQL.
> *** Flex version 2.5.31 or later is required, but this is /usr/bin/lex
> version 2.5.4.
> no
> configure: WARNING:
> *** Without Flex you will not be able to build PostgreSQL from CVS nor
> *** change any of the scanner definition files.  You can obtain Flex from
> *** a GNU mirror site.  (If you are using the official distribution of
> *** PostgreSQL then you do not need to worry about this because the Flex
> *** output is pre-generated.)
> checking for perl... /home/leto/bin/perl
> configure: using perl 
> configure: WARNING:
> *** The installed version of Perl, /home/leto/bin/perl, is too old to use
> with PostgreSQL.
> *** Perl version 5.8 or later is required, but this is .
> configure: WARNING:
> *** Without Perl you will not be able to build PostgreSQL from CVS.
> *** You can obtain Perl from any CPAN mirror site.
> *** (If you are using the official distribution of PostgreSQL then you do
> not
> *** need to worry about this, because the Perl output is pre-generated.)
> checking for main in -lm... yes
> checking for library containing setproctitle... no
> checking for library containing dlopen... -ldl
> checking for library containing socket... none required
> checking for library containing shl_load... no
> checking for library containing getopt_long... none required
> checking for library containing crypt... -lcrypt
> checking for library containing fdatasync... none required
> checking for library containing gethostbyname_r... none required
> checking for library containing shmget... none required
> checking for -lreadline... no
> checking for -ledit... no
> configure: error: readline library not found
> If you have readline already installed, see config.log for details on the
> failure.  It is possible the compiler isn't looking in the proper
> directory.
> Use --without-readline to disable readline support.
> 
> -- 
> Sent via pgsql-bugs mailing list (pgsql-bugs(at)postgresql(dot)org)
> To make changes to your subscription:
> http://www.postgresql.org/mailpref/pgsql-bugs
> 

In response to

pgsql-bugs by date

Next:From: Tom LaneDate: 2010-02-22 20:07:50
Subject: Re: BUG #5339: Version of Perl detected incorrectly
Previous:From: Alvaro HerreraDate: 2010-02-22 20:04:59
Subject: Re: BUG #5339: Version of Perl detected incorrectly

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group