Pavel Stehule <pavel(dot)stehule(at)gmail(dot)com> wrote:
> with actualised oids
I'm checking the patch for commit, and have a couple of comments.
* I think we cannot cache the delimiter at the first call.
SELECT string_agg(elem, delim)
FROM (VALUES('A', ','), ('B', '+'), ('C', '*')) t(elem, delim);
should return 'A+B*C' rather than 'A,B,C'.
* Can we use StringInfo directly as the aggregate context instead of
StringAggState? For the first reason, we need to drop 'delimiter' field
from struct StringAggState. Now it has only StringInfo field.
* We'd better avoiding to call text_to_cstring() for delimitors and elements
for performance reason. We can use appendBinaryStringInfo() here.
My proposal patch attached.
Also, I've not changed it yet, but it might be considerable:
* Do we need better names for string_agg1_transfn and string_agg2_transfn?
They are almost "internal names", but we could have more
NTT Open Source Software Center
In response to
pgsql-hackers by date
|Next:||From: David E. Wheeler||Date: 2010-01-28 03:28:31|
|Subject: Re: Review: listagg aggregate|
|Previous:||From: Andrew Dunstan||Date: 2010-01-28 02:44:55|
|Subject: Re: make everything target|