Skip site navigation (1) Skip section navigation (2)

Re: Hi!

From: Adrian Klaver <aklaver(at)comcast(dot)net>
To: pgsql-odbc(at)postgresql(dot)org
Subject: Re: Hi!
Date: 2009-12-15 16:56:28
Message-ID: 200912150856.28133.aklaver@comcast.net (view raw or flat)
Thread:
Lists: pgsql-odbc
On Tuesday 15 December 2009 7:21:54 am Daniela Mamede d'Almeida wrote:
> Hi List!
> After looking for a suitable pkg for a long time, I've found
> postgresql-devel-8.4.1-1PGDG.rhel4.x86_64.rpm which sounded like what I
> needed! But when I tried to install it, it asked for some dependencies,
> and those dependencies asked for other dependencies... and I almost got
> all Postgres pkg installed by the end, and that's not what I want.
> Isn't there a better way to get pg_config?
>
> Thanks a lot for your help!
> Daniela.
>
>

The thing to keep in mind is that pg_config is just a helper program. To quote 
the docs:

http://www.postgresql.org/docs/8.4/interactive/app-pgconfig.html

"The pg_config utility prints configuration parameters of the currently 
installed version of PostgreSQL. It is intended, for example, to be used by 
software packages that want to interface to PostgreSQL to facilitate finding 
the required header files and libraries. "

In order for pg_config to work the other files/libraries need to be installed.


-- 
Adrian Klaver
aklaver(at)comcast(dot)net

In response to

  • Re: Hi! at 2009-12-15 15:21:54 from Daniela Mamede d'Almeida

Responses

  • Re: Hi! at 2009-12-15 17:16:41 from Daniela Mamede d'Almeida

pgsql-odbc by date

Next:From: Daniela Mamede d'AlmeidaDate: 2009-12-15 17:16:41
Subject: Re: Hi!
Previous:From: Daniela Mamede d'AlmeidaDate: 2009-12-15 15:21:54
Subject: Re: Hi!

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group