Skip site navigation (1) Skip section navigation (2)

Re: per-tablespace random_page_cost/seq_page_cost

From: Alvaro Herrera <alvherre(at)commandprompt(dot)com>
To: Robert Haas <robertmhaas(at)gmail(dot)com>
Cc: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>, Andres Freund <andres(at)anarazel(dot)de>,pgsql-hackers(at)postgresql(dot)org, Greg Stark <gsstark(at)mit(dot)edu>,Josh Berkus <josh(at)agliodbs(dot)com>
Subject: Re: per-tablespace random_page_cost/seq_page_cost
Date: 2009-11-03 11:25:46
Message-ID: 20091103112546.GA7088@alvh.no-ip.org (view raw or flat)
Thread:
Lists: pgsql-hackers
Robert Haas escribió:
> On Mon, Nov 2, 2009 at 12:40 PM, Alvaro Herrera
> <alvherre(at)commandprompt(dot)com> wrote:
> > Robert Haas escribió:
> >
> >> I don't see anything in this code that is very rel-specific, so I
> >> think it would be possible to implement spcoptions by just defining
> >> RELOPT_KIND_TABLESPACE and ignoring the irony, but that has enough of
> >> an unsavory feeling that I'm sure someone is going to complain about
> >> it...  I suppose we could go through and systematically rename all
> >> instances of reloptions to ent(ity)options or storageoptions or
> >> gen(eric)options or somesuch...
> >
> > Maybe I missed part of the discussion, but do these really need to be
> > handled like reloptions instead of like datoptions?  Perhaps the
> > deciding factor is that we want to parse them once and store them in a
> > cache, so like reloptions; the others are used once per connection and
> > then thrown away.
> 
> This may be a stupid question, but what are datoptions?
> 
> $ git grep datoptions

datoptions are gone now, replaced by pg_db_role_settings, but you could
find them in 8.4.  They were an array of options much like reloptions,
except that they didn't go through the reloptions.c code for parsing.

> > If this is the case, then I think we could just decide that their name
> > is reloptions due to hysterical reasons and be done with it.
> 
> Yeah.  It's particularly unfortunate that we call them "reloptions" in
> the code but "storage parameters" in the documentation.  Neither is a
> particularly good name, and having two different ones is extra-poor.
> But I'm fine with leaving the names as they are and moving on, if no
> one objects too much.  Speak now or don't complain about it after I
> write the patch!

Maybe after we move to Git we can rename them in the code?

-- 
Alvaro Herrera                                http://www.CommandPrompt.com/
The PostgreSQL Company - Command Prompt, Inc.

In response to

Responses

pgsql-hackers by date

Next:From: Peter EisentrautDate: 2009-11-03 11:31:14
Subject: Re: new version of PQconnectdb was:(Re: [HACKERS] Determining client_encoding from client locale)
Previous:From: Albe LaurenzDate: 2009-11-03 10:56:30
Subject: Re: backup_label in a crash recovery

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group