Skip site navigation (1) Skip section navigation (2)

Re: Upgrading our minimum required flex version for 8.5

From: Alvaro Herrera <alvherre(at)commandprompt(dot)com>
To: Kevin Grittner <Kevin(dot)Grittner(at)wicourts(dot)gov>
Cc: pgsql-hackers(at)postgreSQL(dot)org, Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
Subject: Re: Upgrading our minimum required flex version for 8.5
Date: 2009-07-02 15:17:59
Message-ID: 20090702151759.GB4698@alvh.no-ip.org (view raw or flat)
Thread:
Lists: pgsql-hackers
Kevin Grittner wrote:
> Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us> wrote:
>  
> > so the new minimum supported version would probably be 2.5.33
> > (2.5.31 was kinda broken for other reasons, and there was no
> > 2.5.32).
> > 
> > Since 2.5.33 is now over three years old, this does not seem like an
> > onerous requirement, but I thought I'd better ask if anyone has an
> > objection?
>  
> You'd be causing problems for SuSE Enterprise users, like us:
>  
> kgrittn(at)CCDEV-DB:/etc/init.d> cat /etc/SuSE-release
> SUSE Linux Enterprise Server 10 (x86_64)
> VERSION = 10
> PATCHLEVEL = 2
> kgrittn(at)CCDEV-DB:/etc/init.d> flex --version
> flex 2.5.31

Keep in mind that if you build from a tarball, the lexer has already
been run elsewhere and you don't need flex.  Since you do some
experimental playing from CVS I guess you could install flex from source
in your environment only ...

-- 
Alvaro Herrera                                http://www.CommandPrompt.com/
The PostgreSQL Company - Command Prompt, Inc.

In response to

Responses

pgsql-hackers by date

Next:From: Tom LaneDate: 2009-07-02 15:18:23
Subject: Re: Upgrading our minimum required flex version for 8.5
Previous:From: Dave PageDate: 2009-07-02 15:12:56
Subject: Re: First CommitFest: July 15th

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group