Skip site navigation (1) Skip section navigation (2)

Re: system database flag?

From: Guillaume Lelarge <guillaume(at)lelarge(dot)info>
To: Jan-Peter(dot)Seifert(at)gmx(dot)de
Cc: pgadmin-support(at)postgresql(dot)org
Subject: Re: system database flag?
Date: 2009-04-23 14:14:09
Message-ID: 200904231614.09785.guillaume@lelarge.info (view raw or flat)
Thread:
Lists: pgadmin-support
Le jeudi 23 avril 2009 à 14:48:29, Jan-Peter(dot)Seifert(at)gmx(dot)de a écrit :
> Hello,
>
> Guillaume Lelarge wrote:
> > > However, when I view the properties of the new template1 in pgAdmin III
> >
> > it
> >
> > > isn't stated that it's a system database anymore. Is it because that
> > > the OID is different from 1 or is there a hidden flag? In pg_database I
> >
> > don't
> >
> > > see any significant difference from other servers' template1?
> > >
> > > Could you tell me, please?
> >
> > Because of the OID.
>
> Thank you very much for your quick reply. So there are no other 'glitches'
> or problems if recreating template1?

None that I know.

> I guess there's no way and it's not
> adviseable to change the OID back to 1?
>

I don't think it is adviseable. The only issue in pgAdmin will be to have this 
catalog in the schemas node. I'm not sure this is really a big deal.


-- 
Guillaume.
 http://www.postgresqlfr.org
 http://dalibo.com

In response to

pgadmin-support by date

Next:From: Rainer BauerDate: 2009-04-24 19:48:20
Subject: pgAdmin not starting my job
Previous:From: Jan-Peter.SeifertDate: 2009-04-23 12:48:29
Subject: Re: system database flag?

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group