Skip site navigation (1) Skip section navigation (2)

Re: SVN Commit by dpage: r7544 - in trunk/pgadmin3: . pgadmin/frm pgadmin/include/utils pgadmin/ui

From: Quan Zongliang <quanzongliang(at)gmail(dot)com>
To: "Dave Page" <dpage(at)pgadmin(dot)org>
Cc: pgadmin-hackers <pgadmin-hackers(at)postgresql(dot)org>
Subject: Re: SVN Commit by dpage: r7544 - in trunk/pgadmin3: . pgadmin/frm pgadmin/include/utils pgadmin/ui
Date: 2009-01-12 11:13:09
Message-ID: 20090112200527.EDF9.4125B4E5@gmail.com (view raw or flat)
Thread:
Lists: pgadmin-hackers
> Good idea. I think a warning is fine - we shouldn't prevent operation entirely.
> 
> Can you work up a patch?

Now, const float SERVER_MIN_VERSION = 7.3f; is defined in pgAdmin3.h.
Add a new variable SERVER_MAX_VERSION here.
When end-users try to connect to db, check the version.
If it is newer, display a warning dialog.
Then the end-users click <OK> button to continue.

Ok?

-----------------------------------------------
Quan Zongliang
quanzongliang(at)gmail(dot)com
CIT Japan:  http://www.cit.co.jp
CIT China:  http://www.citbj.com.cn


In response to

Responses

pgadmin-hackers by date

Next:From: Dave PageDate: 2009-01-12 11:25:09
Subject: Re: SVN Commit by dpage: r7544 - in trunk/pgadmin3: . pgadmin/frm pgadmin/include/utils pgadmin/ui
Previous:From: Matteo BertiniDate: 2009-01-12 10:50:33
Subject: Re: PATCH: Limit 100 default in frmEditGrid.cpp

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group